Smarticz + ZigBee
 
Powiadomienia
Wyczyść wszystko

Smarticz Smarticz + ZigBee

39 Wpisów
8 Użytkownicy
0 Likes
5,524 Wyświetleń
(@fb_dominikmikolajczyk)
Wpisów: 12
Bywalec
Autor tematu
 

Cześć!

Podłączyłem dzisiaj zakupiony router ZigBee CC2531 do Raspberry Pi 4 oraz zainstalowałem Smarticz w najnowszej wersji 2020.2.

Po wstępnej konfiguracji (rozszerzenie partycji na karcie oraz zmiana lokalizacji na PL) uruchomiłem domyślnie wyłączoną kolejkę Mqtt.

Zrestartowałem całą maszynę i po ponownym uruchomieniu zabrałem się za dodawanie urządzeń...

i tutaj jest problem ponieważ nic mi nie wykrywa.

Próbowałem czujniki Sonoff SNZB-01, SNZB-03 i SNZB-04, żadne nie są wykrywane.

 

Ratunku pomocy 🙂

 
Dodane : 27/08/2020 11:00 pm
isom
 isom
(@isom)
Wpisów: 5084
Szef wszystkich szefów Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20
 

@fb_dominikmikolajczyk Cześć

Za mało info żeby coś pomóc, może napisz czy włączyłeś parowanie i debug w pluginie zigbee2mqtt, czyli tak jak na foto poniżej

zigbee1
Jeżeli tak to co widać w logach domoticz ?
Sprawdz te status usługi czyli
 
systemctl status zigbee2mqtt.service
 
W logach powinieneś widzieć wykryty sniffer ( router) jak nie ma nic  to sprawdź czy malina wykrywa ten moduł
 
ls -l /dev/ttyACM0
 
i powinno być coś w tym stylu 
 ls
 
Dodane : 28/08/2020 8:50 am
(@fb_dominikmikolajczyk)
Wpisów: 12
Bywalec
Autor tematu
 

Tak, mam tak włączone.

Tak się teraz zastanawiam czy to jest poprawnie bo jak widać na screenie mam jakby dwa urządzenia:

zigbee2mqtt (kolejka) i MQTT.

zigbee2mqtt nie ma portu 1883, jest on zajęty przez  MQTT.

Poniżej screeny z zapytaniami o których pisałeś.

 

ls -l /dev/ttyACM0
ls
 
systemctl status zigbee2mqtt.service
services
 
Dodane : 28/08/2020 9:37 am
pawell32
(@pawell32)
Wpisów: 1186
Guru
 

@fb_dominikmikolajczyk

wpisz sudo journalctl -u zigbee2mqtt.service -f

i zobacz co widzi
 

 
Dodane : 28/08/2020 10:13 am
(@fb_dominikmikolajczyk)
Wpisów: 12
Bywalec
Autor tematu
 

@pawell32

 

journalctl
 
Dobrze czytam że rozpoznał jakieś urządzenie ale nie jest wspierane? Pewnie chodzi o SZNB-03 jednak na stronie o CC2531 jest wymienione jako urządzenie współpracujące.
 
Dodane : 28/08/2020 10:20 am
isom
 isom
(@isom)
Wpisów: 5084
Szef wszystkich szefów Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20
 

@fb_dominikmikolajczyk

Smarticz był wdrożony jakiś czas temu a wspieranych urządzeń ciągle przybywa, więc trzeba zaktualizować plugin

cd domoticz/plugins/zigbee2mqtt

potem

git pull

i na koniec restart maliny 

 
Dodane : 28/08/2020 10:29 am
(@fb_dominikmikolajczyk)
Wpisów: 12
Bywalec
Autor tematu
 

@isom

Dziękuję, tego brakowało.

Z jednym czujnikiem pomogło, wieczorem sprawdzę czy resztę też już widzi.

 
Dodane : 28/08/2020 11:20 am
(@fb_dominikmikolajczyk)
Wpisów: 12
Bywalec
Autor tematu
 

Jednak nie ma tak kolorowo 🙁

 

Nie wiem co to jest to urządzenie na screenie, pojawia się po wykonaniu aktualizacji o której pisał @isom

zigbee2
 
 

Okazało się że to co myślałem że jest czujką Sonoff to nią nie jest. W dalszym ciągu wszystkie urządzenia nie są rozpoznawane - dołączam wynik zapytania sudo journalctl -u zigbee2mqtt.service –f

 
Dodane : 28/08/2020 2:02 pm
isom
 isom
(@isom)
Wpisów: 5084
Szef wszystkich szefów Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20
 

@fb_dominikmikolajczyk

Co masz kolego w urządzeniach nieużywanych w domoticz ?

Zobacz co się dodało w configuration.yaml

cat /opt/zigbee2mqtt/data/configuration.yaml

najlepiej wrzuć fotę

 

 

 
Dodane : 28/08/2020 3:16 pm
(@fb_dominikmikolajczyk)
Wpisów: 12
Bywalec
Autor tematu
 

@isom

Trzy wpisy czyli tyle ile urządzeń próbowałem podłączyć.

 

 devices
 
Dodane : 28/08/2020 4:18 pm
isom
 isom
(@isom)
Wpisów: 5084
Szef wszystkich szefów Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20
 

@fb_dominikmikolajczyk wygląda prawidłowo, sprawdź jeszcze 

cat /opt/zigbee2mqtt/data/state.json

Jak będą też wpisy z tymi ID to zobacz zawartość bazy

cat /opt/zigbee2mqtt/data/databasse.db

Jak  nie będzie pusta to ok, jesli dalej nie ma urządzeń w domoticz, możesz w domoticz Sprzęt - zigbee2mqtt kliknąć aktualizuj i zobacz czy wtedy się pojawią urządzenia i koniecznie zobacz logi w domoticz po tym jak aktualizujesz sprzęt .

 
Dodane : 28/08/2020 6:49 pm
(@fb_dominikmikolajczyk)
Wpisów: 12
Bywalec
Autor tematu
 

@isom

po wykonaniu

cat /opt/zigbee2mqtt/data/state.json

nic się nie wyświetla

Mam bez żadnych zmian kliknąć aktualizuj? Tak jak na screenie?

zigbee4

 

Bez zmian.

Gdzie znajdę logi domoticz o które pytasz?

 
Dodane : 28/08/2020 7:24 pm
isom
 isom
(@isom)
Wpisów: 5084
Szef wszystkich szefów Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20
 

@fb_dominikmikolajczyk tak chciałem żebyś aktualizował sprzęt bez żadnych zmian bo czasem to pomaga, ale nie w tym przypadku ponieważ masz pusty plik state.json a powinien wyglądać tak jak na foto

json
Sprawdzałeś zawartość bazy danych ?
Zobacz te logi w domoticz może wali błędami i będzie więcej wiadomo 
 log
 
Dodane : 28/08/2020 7:44 pm
(@fb_dominikmikolajczyk)
Wpisów: 12
Bywalec
Autor tematu
 

@isom

O jakie bazy pytasz czy sprawdzałem?

 

W domoticz logach (błędy) mam tylko 1 zerwanie połączenia

 

 

 

 zigbee5
 
Dodane : 28/08/2020 8:44 pm
isom
 isom
(@isom)
Wpisów: 5084
Szef wszystkich szefów Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20
 

@fb_dominikmikolajczyk kilka postów wyżej podałem komendę do sprawdzenia zawartości  database.db

cat /opt/zigbee2mqtt/data/database.db
zobacz co tam jest , zobacz też co masz w oknie własne zaznaczyłem na foto
 1598635490 zigbee4
 
Dodane : 28/08/2020 8:54 pm
(@fb_dominikmikolajczyk)
Wpisów: 12
Bywalec
Autor tematu
 

@isom

poniżej database:

 

database
 
We własnych jest ciekawie, to są chyba te urządzenia. Ciągle sprawdzałem w kofiguracja-> urządzenia a tu nie zaglądałem.
 wlasne
 
Dodane : 28/08/2020 9:00 pm
isom
 isom
(@isom)
Wpisów: 5084
Szef wszystkich szefów Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20
 

@fb_dominikmikolajczyk aktualizuj ten sprzęt bez zmian tak jak prosiłem wcześniej i sprawdź logi w domoticz po tej aktualizacji . Najlepiej skopiuj wszystko co dotyczy zigbee ( na górze po lewej masz filtrowanie jak wpiszesz "zigbee" to wszystko inne zniknie

 
Dodane : 28/08/2020 9:10 pm
(@fb_dominikmikolajczyk)
Wpisów: 12
Bywalec
Autor tematu
 

@isom

dałem Konfiguracja->sprzęt->zigbee2mqtt->Aktualizuj

 

Logi Domoticza w załączniku poniżej:

 zigbee6
 
Dodane : 28/08/2020 10:56 pm
(@fb_dominikmikolajczyk)
Wpisów: 12
Bywalec
Autor tematu
 

Na stronie https://www.zigbee2mqtt.io/devices/SNZB-01.html jest opisane moje urządzenie (więc teoretycznie jest wspierane).

Jest tutaj opisane "Manual Home Assistant configuration" oraz podany kod który należy wpisać gdy urządzenie nie jest rozpoznane.

Czy ma to również zastosowanie do Domoticza?

 
Dodane : 29/08/2020 1:52 pm
isom
 isom
(@isom)
Wpisów: 5084
Szef wszystkich szefów Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20
 

@fb_dominikmikolajczyk U Ciebie sytuacja wygląda całkiem dobrze, przynajmniej tak wynika z ostatnich logów które wstawiłeś. Problemem jest parowanie urządzeń, które poszło nie tak i trzeba to naprawić.

Proponuję usunąć wszystkie trzy urządzenia z zakładki WŁASNE i dodanie ich jeszcze raz .

Na focie poniżej masz kolejność czynności i krótki opis, który postaram się tu uzupełnić. 

1598641299 wlasne
Usuwanie tak jak w opisie zaznaczasz force i do widzenia W punkcie 2 po kliknięciu okienka Pair Device otworzy się okno i system będzie czekał na sygnał z urządzenia np czujnik otwarcia . wciskasz przycisk parowania na czujniku i dłuższej chwili powinieneś w tym oknie zobaczyć Adres tego czujnika , jak już jest adres to naruszasz czujnik przykładając i odkładając magnes (ta mniejsza część) , w wyżej wymienionym oknie powinieneś zobaczyć opis tego urządzenia np Door Sensor Sonoff , jak nie będzie opisu to spróbuj naruszyć czujnik jeszcze raz . Jak już będzie ten opis to zamykasz okno parowania i na liście znajdziesz nowe urządzenie ale już z dodanym opisem w oknie Description, klikasz na ołówek (Zmień nazwę urządzenia) i wpisujesz sobie własną nazwę zamiast tego długiego adresu.
Przechodzisz do Konfiguracja - Urządzenia i we wszystkich lub w nieużywanych urządzeniach powinieneś znaleźć swój czujnik i wszystkie dodatkowe urządzenia z nim związane np stan baterii , siła sygnału itp.
Taka sama procedura dotyczy przycisku , czujnika PIR itd.
Jak prawidłowo sparujesz czujnik to w zakładce własne powinno to wyglądać podobnie do tego 
 zigi
 
Dodane : 29/08/2020 4:51 pm
Strona 1 / 2
Udostępnij: