Forum Smart'ny Dom

ImperiHome do Domot...
 

ImperiHome do Domoticz - pierwsze kroki  

Strona 2 / 2
  RSS
gregaicha
(@gregaicha)
Początkujący

zaznacze od razu że uzywam najnowszego obrazu 17-02-2019-Domoticz-4970_v13_Pack

poprzednio nie miałem tego problemu na wersji 20-01-2019-Domoticz_v11_Pack

po wejsciu na strone http://http://172.16.3.3:3002/devices

dostaje komunikat  Unable to connect to Domoticz

w sieci lokalne bez hasła mam taki wpis 127.0.0.*;172.16.3.*;10.1.9.*

co mogę jeszcze sprawdzić ???

 

 

{"devices":[{"id":"S00","name":"Unable to connect to Domoticz","type":"DevGenericSensor","room":"Utility","params":[{"key":"Value","value":"http://127.0.0.1:8080/json.htm"}]},{"id":"S01","name":"Please add this gateway in Setup/settings/Local Networks","type":"DevGenericSensor","room":"Utility"}]}

 

OdpowiedzCytuj
Dodane : 18/02/2019 9:57 pm
isom
 isom
(@isom)
Zasłużony Moderator

Dobrze, że od tego zacząłeś  musisz się uzbroić w cierpliwość ponieważ nad  poprzednią mocno roboczą wersją na której MyDomoAtHome był skonfigurowany i działał pracowałem ja , natomiast docelowy obraz muszę najpierw pobrać i sprawdzić , albo skonsultować to z kolegą @abulec , bo to on finalizował ostateczny kształt obrazu.

OdpowiedzCytuj
Dodane : 18/02/2019 10:16 pm
skalarro
(@skalarro)
Młodzik

A powiedzcie mi ludzie obeznani w temacie - są gdzieś w mdah ustawienia  danych na serwerze? Przeszkadza mi trochę duże opóźnienie od kliknięcia w klawisz w ImpreiHome do wykonania polecenia. W domoticzu idzie to duuuużo szybciej. Wiem, że dane mają dłuższą drogę ale może gdzieś jest jakaś opcja żeby skrócić ten czas?

OdpowiedzCytuj
Dodane : 18/02/2019 10:19 pm
gregaicha
(@gregaicha)
Początkujący

zaznaczę tylko że w tym nowym obrazie 17-02-2019-Domoticz-4970_v13_Pack nie działa mi ImperiHome ale działa mi shelly

w poprzednim 20-01-2019-Domoticz_v11_Pack nie działał mi shelly ale działał mi ImperiHome.

xiaomi gatwey wraz czujkami ruchu, przyciskami i temperatura i żarówkami yeelight działa i tu i tu bez problemu 🙂

OdpowiedzCytuj
Dodane : 18/02/2019 10:28 pm
isom
 isom
(@isom)
Zasłużony Moderator

Ok to akurat pamiętam 

OdpowiedzCytuj
Dodane : 18/02/2019 10:38 pm
abulec
(@abulec)
Początkujący

@gregaicha odpal SSH i wpisz:

 

sudo nano /etc/mydomoathome/config.json

Zmień port na 8084

ctrl+x ---> TAK ---> Enter

 

sudo service mydomoathome restart

 

I będzie dobrze. Jutro to poprawię plus kilka innych drobnych rzeczy i wrzucę uaktualniony obraz.

 

OdpowiedzCytuj
Dodane : 18/02/2019 11:32 pm
gregaicha polubień
abulec
(@abulec)
Początkujący

@skalarro z moich doświadczeń wynika, że to problem z mocą obliczeniowej maliny. Taka sama konfiguracja np na synology nie miała tego problemu, wszystko chodziło szybko.

OdpowiedzCytuj
Dodane : 19/02/2019 1:04 am
gregaicha polubień
gregaicha
(@gregaicha)
Początkujący
sudo nano /etc/mydomoathome/config.json

tu już zacząłem kombinować tylko z adresem ip, portu nie ruszałem czy to znaczy że w aplikacji ma telefonie
będę musiał użyć portu 8084
Teraz z tego co pamietam przy porcie 3002 na końcu jest przecinek tak ma być ??

sprawdzę to dzisiaj po przyjściu z pracy :)

 

OdpowiedzCytuj
Dodane : 19/02/2019 7:29 am
skalarro
(@skalarro)
Młodzik

Nie,

8084 to port domoticza. A aplikacji używasz portu na którym mydomoathome wystawia dane dla aplikacji czyli 3002. 8084używany jest do pobrania danych z domoticza przez MyDomoAtHome

OdpowiedzCytuj
Dodane : 19/02/2019 7:39 am
gregaicha polubień
isom
 isom
(@isom)
Zasłużony Moderator

Dokładnie tak jak napisał @skalarro , bedziesz w apce dalej korzystał z portu 3002 a plik konfiguracyjny powinien wyglądać tak

{
"app_name": "MyDomoAtHome",
"auth": null,
"domoticz": {
"ssl": false,
"host": "127.0.0.1",
"port": "8084",
"path": "/",
"auth": null
},
"port": 3002,
"passcode": ""
}

 

Możesz to sobie jeszcze bardziej spersonalizować zmieniając adres IP na adres maliny 

OdpowiedzCytuj
Dodane : 19/02/2019 7:41 am
gregaicha polubień
gregaicha
(@gregaicha)
Początkujący

wszystko działa jest tak jak napisaliście 

 

OdpowiedzCytuj
Dodane : 20/02/2019 1:44 pm
gregaicha
(@gregaicha)
Początkujący

wiem że działało :)) ale znowu mam jakiś problem:( nie działa mi ImperiHome

po wpisaniu adresu i portu http://http://172.16.3.3:3002/devices cisz nie można odnaleźć strony 

wydaje mi się ze nic nie robiłem..

Restart usługi jaki i maliny nic nie daje co mogę jeszcze zrobić ??

OdpowiedzCytuj
Dodane : 13/03/2019 4:43 pm
isom
 isom
(@isom)
Zasłużony Moderator

Możesz spróbować 

sudo service mydomoathome reload

albo 

sudo systemctl daemon-reload

i na koniec 

sudo service mydomoathome status

jak usługa nie ruszy to wrzuć fotę z tego statusu 

OdpowiedzCytuj
Dodane : 13/03/2019 6:08 pm
gregaicha
(@gregaicha)
Początkujący

cokolwiek to znaczy :)))

 

● mydomoathome.service - MDAH ISS Rest interface for Domoticz to Imperihome
Loaded: loaded (/etc/systemd/system/mydomoathome.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2019-03-13 20:00:54 CET; 2min 26s ago
Main PID: 14677 (mydomoathome)
CGroup: /system.slice/mydomoathome.service
├─14677 /bin/bash /usr/share/mydomoathome/bin/mydomoathome
└─14680 node /usr/bin/forever --minUptime 5000 --spinSleepTime 2000 --max-old-space-size=128 -a -l /var/log/mydomoathome/mdah.log /usr/share/mydomoa

mar 13 20:03:19 raspberrypi MDAH[14677]: at Object.runInThisContext (vm.js:139:10)
mar 13 20:03:19 raspberrypi MDAH[14677]: at Module._compile (module.js:616:28)
mar 13 20:03:19 raspberrypi MDAH[14677]: at Object.Module._extensions..js (module.js:663:10)
mar 13 20:03:19 raspberrypi MDAH[14677]: at Module.load (module.js:565:32)
mar 13 20:03:19 raspberrypi MDAH[14677]: at tryModuleLoad (module.js:505:12)
mar 13 20:03:19 raspberrypi MDAH[14677]: at Function.Module._load (module.js:497:3)
mar 13 20:03:19 raspberrypi MDAH[14677]: at Module.require (module.js:596:17)
mar 13 20:03:19 raspberrypi MDAH[14677]: at require (internal/module.js:11:18)
mar 13 20:03:19 raspberrypi MDAH[14677]: at Object.<anonymous> (/usr/share/mydomoathome/app/node_modules/request/node_modules/tough-cookie/lib/cookie.js:34
mar 13 20:03:19 raspberrypi MDAH[14677]: error: Forever detected script exited with code: 1

OdpowiedzCytuj
Dodane : 13/03/2019 8:07 pm
isom
 isom
(@isom)
Zasłużony Moderator

Wygląda na problem z węzłem node , co ostatnio instalowałeś ? sprawdź wersję 

 node -v

i przy okazji 

npm -v

powinny być 

node v 8.11.1

npm 3.10.3

jak jest wyższa wersja node to będzie problem 

OdpowiedzCytuj
Dodane : 13/03/2019 9:39 pm
gregaicha
(@gregaicha)
Początkujący

pi@raspberrypi:~ $ node -v
v8.11.1
pi@raspberrypi:~ $ npm -v
3.10.3
pi@raspberrypi:~ $

wygląda na to że wersje są takie jak napisałeś 

wydaje mi się że nic nie instalowałem 

OdpowiedzCytuj
Dodane : 13/03/2019 10:41 pm
jokers
(@jokers)
Młodzik
Dodane przez: gregaicha

wiem że działało :)) ale znowu mam jakiś problem:( nie działa mi ImperiHome

po wpisaniu adresu i portu http://http://172.16.3.3:3002/devices cisz nie można odnaleźć strony 

wydaje mi się ze nic nie robiłem..

Restart usługi jaki i maliny nic nie daje co mogę jeszcze zrobić ??

Ja mam dokładnie tak jak kolega powyżej napisał tyle że wydaje mi się że to wina domoticza a nie MDAH dlatego że jak zapyta się domoticza w taki sposób :
http://192.168.3.113:8084/json.htm
to on odpowiada błędem:

{
   "status" : "ERR"
}

a tak chyba nie powinno być. U mnie zaczęło się tak dziać jak domoticza zabezpieczyłem hasłem, teraz nawet usunięcie hasła w domoticzu nie pomaga, cały czas nie widzi devices
OdpowiedzCytuj
Dodane : 14/03/2019 7:12 pm
gregaicha
(@gregaicha)
Początkujący

http://172.16.3.3:8084/json.htm

{
   "status" : "ERR"
}

tak samo 

OdpowiedzCytuj
Dodane : 14/03/2019 9:19 pm
Strona 2 / 2
Udostępnij:



Udostępnij
  • 1
    Share
  
Pracuję

Proszę Zaloguj Się lub Zarejestruj