Smarticz 2020.2 + n...
 
Powiadomienia
Wyczyść wszystko

Smarticz 2020.2 + najnowszy Raspberry OS + USB Boot na RPi 4B  

Strona 2 / 2
wo__jo
(@wo__jo)
Młodzik

Witam,

mam problem z uruchomieniem Smarticza z dysku ssd z pendrive uruchamia się bez problemu natomiast z dysku nie chce ruszyć, co ciekawe po wgraniu Raspberry PI OS lite bez problemu startuje z dysku ssd. Zmieniłem przejściówkę USB na polecaną w wątku i niestety nie pomogło na PI OS Lite działają przejściówki UGREEN oraz jakaś Chińska oparta na JMicron.

W najgorszym razie trzeba będzie instalować wszystkie dodatki samodzielnie więc nie ma jakiegoś problemu ale zgłaszam problem dla zasady.

Pacjent to PI 4B 2GB.

OdpowiedzCytuj
Dodane : 03/12/2020 8:05 pm
kluczyk
(@kluczyk)
Początkujący

Ja mam Pi 4B 4GB ale myślę to nie jest problemem. Jaki masz błąd podczas uruchamiania z Raspberry Pi przez SSD? Zmieniałeś Bootloadera?

Ja robiłem to tak:

1. Wgrałem Raspberry Pi OS na kartę SD.
2. Uruchomiłem system i zaktualizowałem Bootloader.
3. Wyjąłem kartę SD
3. Wgrałem na dysk SSD (podłączony przez przejściówkę) Smarticza 2020.2 (np. Rufus na Windows 10)
4. Uruchomiłem smarticza (bez błędów na UGREEN)
5. Zrobiłem upgrade do najnowszej wersji Raspberry OS 

i wszystko działa bez problemu.

Na taniej przejściówce JMicron miałem błąd /dev/serial1 jak na załączonym obrazku

OdpowiedzCytuj
Autor tematu Dodane : 03/12/2020 8:14 pm
wo__jo
(@wo__jo)
Młodzik

@kluczyk

U mnie się nawet nie boot-uje ERROR000044 na ekranie startowym (na tym na którym jest kod QR). Raspberry zaktualizowane, Bootloader zaktualizowany Raspberry PI OS Lite uruchamia się z dysku, Smarticz nie. Przed chwilą pobrałem jeszcze raz obraz i dalej bez zmian czyli z Pena działa a z Dysku nie. Pobiorę jeszcze wersję 2020 i sprawdzę czy coś się zmieni.

OdpowiedzCytuj
Dodane : 03/12/2020 8:42 pm
kluczyk
(@kluczyk)
Początkujący

@wo__jo Sprawdź dysk. Może źle wgrałeś. Ja miałem problemy z BalenaEtcher. Skoro Raspberry OS Lite działa, to ja obstawiam w źle wgrany obraz Smarticza 2020.2 na SSD. Czym wgrywasz Smarticza na SSD? Ewentualnie jak to nie pomoże wgraj Smarticza na SD, uaktualnij całość do najnowszej wersji, zrób obraz dysku SD, wgraj go na SSD i powinno działać.

OdpowiedzCytuj
Autor tematu Dodane : 03/12/2020 8:45 pm
isom polubień
voytec
(@voytec)
Młodzik

@kluczyk

Czyli przejściówki Ugreen mamy takie same. 

OdpowiedzCytuj
Dodane : 03/12/2020 11:13 pm
voytec
(@voytec)
Młodzik
Dodane przez: @kluczyk

@wo__jo Sprawdź dysk. Może źle wgrałeś. Ja miałem problemy z BalenaEtcher. Skoro Raspberry OS Lite działa, to ja obstawiam w źle wgrany obraz Smarticza 2020.2 na SSD. Czym wgrywasz Smarticza na SSD? Ewentualnie jak to nie pomoże wgraj Smarticza na SD, uaktualnij całość do najnowszej wersji, zrób obraz dysku SD, wgraj go na SSD i powinno działać.

Ja wgrywałem obraz na SSD trzema różnymi programami. Błąd zawsze był taki sam. Wgrałem też na kartę SD 2020.2 i sklonowalem na SSD i błąd taki sam jak wcześniej.

Natomiast po sklonowaniu mojej starej instalacji smarticza (chyba V5) z karty SD na dysk SSD wystartował bez błędu. 

OdpowiedzCytuj
Dodane : 03/12/2020 11:22 pm
wo__jo
(@wo__jo)
Młodzik

@voytec

Czyli nie tylko ja mam taki problem. Próbowałem wgrywać różnymi programami bez pozytywnego rezultatu.

Żeby było ciekawiej to wystartowałem malinę z Pena ale zapomniałem odpiąć dysk ze Smarticzem i okazało się, że boot ruszył z pena ale system załadował się z dysku :).

Więc niestety na tą chwilę jedynym wyjściem jest instalacja PI OS a potem reszty, czego bardzo mi się nie chce.

 

OdpowiedzCytuj
Dodane : 04/12/2020 7:11 pm
Strona 2 / 2
Udostępnij: