Powiadomienia
Wyczyść wszystko

[Rozwiązany] Sonoff S20 wgranie firmware

Michał Lewecki
(@g_michal-lewecki)
Początkujący

Cześć,

zakupiłem nowe sonoff S20 i chciałem wypróbować je z AFE. Posiadam 3 moduły w wersji pcb 1.3 i każdy zachowuje się tak samo tzn. mogę wgrać firmware prze NodeMCU, ale po podłączeniu do zasilania nie dzieje się nic (brak rozgłaszanych sieci).

Próbowałem wersji 1.0.1.T0, 1.0.0.T2 i 0.8. Na wszystkich to samo. Jakieś rady co bym mógł sprawdzić?

 

Autor tematu Dodane : 06/01/2018 9:40 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

mruga dioda w S20?

Dodane : 06/01/2018 10:06 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

spróbuj jeszcze wgrać wersję 8285

https://www.smartnydom.pl/download/afe-firmware-t0-esp8285-1mb/?wpdmdl=2583

Dodane : 06/01/2018 10:12 pm
Michał Lewecki
(@g_michal-lewecki)
Początkujący

Niestety dioda nie daje żadnych oznak. Moduł mogę przeprogramować bezproblemowo.

Autor tematu Dodane : 06/01/2018 10:12 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

wgraj wersję ESP8285

Dodane : 06/01/2018 10:13 pm
Michał Lewecki
(@g_michal-lewecki)
Początkujący

Wgrałem do jednego wersje T0 i ten sam efekt.

Rozbebeszyłem drugi moduł i sprawdziłem jakie ESP tam siedzi. Jest to 8266EX

Autor tematu Dodane : 06/01/2018 10:33 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

spóbuj jeszcze inne SPI_MODE, jeśli wgrywasz QIO to użyj DOUT lub odwrotnie, a jak nie pójdzie to jeszcze DIO

podeślij jeszcze może screenshot z zakładki Config

Dodane : 06/01/2018 10:36 pm
Michał Lewecki
(@g_michal-lewecki)
Początkujący

Zmiana z QIO na DOUT załatwiła sprawę.

Mylące było to, że programowanie przechodziło pomyślnie na quad I/O.

Bardzo dziękuję za szybką pomoc. Zabieram się za dalszą konfigurację.

Mogę teraz w pełni pobawić się zestawem 3xS20 + 2xBasci + Mqtt + OpenHub na Raspi.

pozdrawiam,

Autor tematu Dodane : 06/01/2018 10:47 pm
adrian polubień
Udostępnij: