Powiadomienia
Wyczyść wszystko

Problem Sonoff Basic samoczynne włączanie się przekaźnika

12 Wpisów
4 Użytkownicy
1 Reactions
966 Wyświetleń
isom
Wpisów: 5100
 isom
Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20
(@isom)
Szef wszystkich szefów
Dołączył: 6 lat temu

@wo__jo odłącz na próbę przycisk od przekaźnika, tzn ustaw w konfiguracji przycisku sterowanie przekaźnikiem - Brak

Jak to nic nie zmieni to wstaw fotki z konfiguracji, mam u siebie około 20 urządzeń z AFE T0 3.7.1 i wszystko pracuje bez problemów

Odpowiedz
1 Reply
Donator 2K23 Donator 2K21
(@wo__jo)
Dołączył: 6 lat temu

Praktykant
Wpisów: 17

@isom po wyłączeniu dodatkowego przełącznika wszystko wróciło do normy. Co proponujesz zrobić żeby móc używać dodatkowy przycisk.

Poniżej screeny z konfiguracją, przed aktualizacją działał prawidłowo.

AFE Zawór 6
AFE Zawór 4
Odpowiedz
isom
Wpisów: 5100
 isom
Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20
(@isom)
Szef wszystkich szefów
Dołączył: 6 lat temu

Dodane przez: @wo__jo

Co proponujesz zrobić żeby móc używać dodatkowy przycisk

Ja proponuję zostawić przycisk na GPIO 0 jako systemowy, a dodatkowy switch zrobić na GPIO 14. Pisałeś, że na starym sofcie działało, więc masz pewnie dość starego sonoff i GPIO 14 jest dostępne bez problemu. Jedno co jest ważne przy długich przewodach do takiego switcha to pullup sprzętowy, a nie programowy, czyli łączysz to GPIO14 z 3,3V przez rezystor 10k, a włącznik dajesz miedzy GND a GPIO14. Takie połączenie ustawia na sztywno stan wysoki i bardzo trudno to zakłócić, natomiast zwarcie do masy daje 100% stan niski.  

Odpowiedz
1 Reply
Donator 2K23 Donator 2K21
(@wo__jo)
Dołączył: 6 lat temu

Praktykant
Wpisów: 17

@isom też mi się wydaje, że to wina zakłóceń, cofnąłem się softem do 3.3.3 i dalej było to samo. Uspokoiło się dopiero jak zmieniłem wyzwalanie przekaźnika sygnałem LOW. LED i przełącznik działa prawidłowo, tylko w Domoticzu przełącznik działa na odwrót poradziłem sobie dokładając przełącznik wirtualny działający na odwrót i znowu jest problem z dodatkowym przełącznikiem fizycznym który nie wysterowuje  przełącznika wirtualnego w Domoticzu  🙂 Próbowałem to zrobić na zmiennych użytkownika ale są lagi i nie działa to za każdym razem, a jest to sterowanie zaworem w ogrodzie i używa go żona więc musi działać tak żebym miał spokój.

Niby prosta spraw a poległem

Odpowiedz
Strona 2 / 2
Udostępnij: