Jaki dysk SSD i ada...
 
Powiadomienia
Wyczyść wszystko

Jaki dysk SSD i adapter do Raspberry Pi 4B+  

bartolomeo
(@bartolomeo)
Majster

Cześć,

Ostatnio jedną błędną komendą usunąłem sobie chyba folder  /usr/bin/python3 przez co nie wykonują mi się różne inne operacje np. apt-get upgrade. Nie umiem tego naprawić, chociaż wszystko czego potrzebuję jak i sam Domoticz nadal śmiga. Tak czy siak chyba postawię to po raz kolejny i pomyślałem, że tym razem już porządnie na dysku SSD.

Nie znalazłem na forum konkretów a znam się na tym średnio, więc żeby nie kupować w ciemno zapytam jaki dysk SSD najlepiej kupić.

  • Domyślam się, że ma być niedużej pojemności, ale czy 16 GB czy 120 GB?
  • Gdzieś krążyły plotki, że 2,5", ale czy rozmiar fizyczny ma znaczenie?
  • Pobór mocy też chyba istoty.
  • Ale najważniejsza trwałość przy rozsądnej cenie.

Do tego jakaś przejściówka np. SATA-USB, tak? Jak długa może/powinna być ta przejściówka? I czy taki dysk się bardzo grzeje i czy potrzebuje jakiś specjalnych warunków pracy. Jest to dla mnie o tyle istotne, że muszę zaplanować gdzie umieszczę ten dysk. Najwygodniej byłoby mi dać z 1m przejściówki i położyć go na strychu (tam zakres temperatur pewnie -10 / + 30), lub pod wełną na suficie za karton gipsem (tam temp pokojowa o ile sam dysk nie odda zbyt duży ciepła). Ale jeśli przejściówka musi być jak najkrótsza, to poradzę sobie umieszczając go gdzieś w puszcze w ścianie, bo w obudowie w której obecnie mam Raspberry raczej nie da rady.

Jak zawsze z góry dziękuję za rady.

Cytuj
Autor tematu Dodane : 04/11/2020 2:08 pm
maras
(@maras)
Majster Donator 2019
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2019, Donator 2K20

Co do dysków to zgadzam się z @maras , ale do RPI4 adapter chyba lepszy będzie taki https://www.morele.net/kieszen-axagon-adapter-sata-na-usb-3-0-czarny-adsa-fp2-939508/

Nie wiele droższy a parametry dużo lepsze

Można podłączyć przez przedłużacz usb dobrej jakości i do 2 m bez problemu da radę 

OdpowiedzCytuj
Dodane : 04/11/2020 8:41 pm
bartolomeo polubień
Michal_M
(@michal_m)
Stażysta

Cześć, Co do dysku się zgadzam z @maras -  używam akurat tego 120GB PNY z linku oraz wersji 240GB też PNY - bez problemów. PNY 120GB po ponad 12 miesiącach non-stop na Pi4 z dużą liczbą zapisów (testowy sprzęt dla innych projektów) ma nadal świetne wartości testów.

Co do przejściówki  - tutaj jest sporo wątków w necie - jedne działają OK a inne nie. Nie podpowiem nic o przejściówce @isom ale juz kilka razy gdzieś na forum podawałem stronę na której można sprawdzić działanie adapterów - LINK- co nie oznacza że inne nie chodzą, ale te z listy chodzą - mam kilka adapterów StarTech i bez problemu.

OdpowiedzCytuj
Dodane : 05/11/2020 1:21 pm
bartolomeo
(@bartolomeo)
Majster

Dzięki za porady!

Wczoraj zamówiłem ten dysk Patriot 120GB 2,5" SATA SSD BURST oraz przejściówkę poleconą przez Isom - Axagon. Do tego taki przedłużacz USB. Jak dotrą to podejdę do tematu.

Jeden z tych  sprawdzonych adapterów (albo bliźniaczo podobny) kosztuje jedyne 15zł na allegro, więc uważam, że ten ponad 2x droższy powinien być petardą 😉 

OdpowiedzCytuj
Autor tematu Dodane : 05/11/2020 2:55 pm
Michal_M
(@michal_m)
Stażysta

@bartolomeo pewnie racja, nie mam porównania więc nie powiem czy StarTech to petarda czy zwykły kapiszon 🙂 ale jak mawiają "skoro nie widać różnicy"... daj znać jak poszło i jak działa ten co zamówiłeś - przyda się info, bo zainteresowanie dyskami SSD na forum coraz większe odkąd na Pi4 chodzi  "prosto z pudełka"

OdpowiedzCytuj
Dodane : 05/11/2020 5:38 pm
bartolomeo
(@bartolomeo)
Majster

Hej, dopiero dziś podszedłem do tego tematu. Generalnie hardware chyba śmiga (aczkolwiek miałem problem z wgraniem obrazu na tej 1,5 metrowej przedłużce - kończyło się przerwaniem procesu - na samym adapterze problemu z wgraniem nie było).

Tylko i tak nie chce mi się uruchomić nic z tego dysku... Czy SSD działa na RPI 4B+ "out of the box", czy muszę coś konfigurować wcześniej na Raspberry? Próbowałem różnych opisów znalezionych w sieci, ale większości przejść nie mogę ze względu na wspomniany w pierwszym poście błąd typu:

E: Podproces /usr/bin/apt-listchanges --apt || test $? -lt 10 zwrócił kod błędu (1)
E: Failure running script /usr/bin/apt-listchanges --apt || test $? -lt 10

Podpowiedzcie proszę jakie kroki wykonać lub co sprawdzić, żebym nie błądził jak dziecko we mgle.

 

OdpowiedzCytuj
Autor tematu Dodane : 22/11/2020 11:09 pm
steel_rat
(@steel_rat)
Brygadzista

Z tego korzystałeś?

https://www.tomshardware.com/how-to/boot-raspberry-pi-4-usb

OdpowiedzCytuj
Dodane : 22/11/2020 11:17 pm
bartolomeo
(@bartolomeo)
Majster

@steel_rat. Tak, m.in. z tego, ale nie mogłem przejść przez wadę na systemie. Wgrałem zatem teraz czysty obraz na kartę SD, zrobiłem upgrade wg. instrukcji z załącznika (trochę różni się menu w raspi-config), wyjąłem kartę, podłączyłem dysk (nadal bez przedłużacza dla pewności) i nic... Nie wstaje - nie wykrywa....

OdpowiedzCytuj
Autor tematu Dodane : 23/11/2020 9:37 am
steel_rat
(@steel_rat)
Brygadzista

Nie napisałeś skopiowałeś dane z kart sd na ssd? Ja wczoraj na, co prawda RP2, przenosiłem dane z sd na ssd. I wszystko działa. Co prawda RP2 wymaga kardy do startu ale dało radę.

OdpowiedzCytuj
Dodane : 23/11/2020 10:23 am
bartolomeo
(@bartolomeo)
Majster

Na dysku SSD był nowy czysty obraz pobrany ze smarticz.eu bo taki był zamysł by postawić system od nowa. Po napisaniu posta kombinowałem dalej i zgrałem w końcu stary obraz z karty, wgrałem na dysk, ale to chyba bez znaczenia, bo w końcu zacząłem kombinować ze zmianą gniazda USB i to pomogło... Zbootowało.

Czy to normalne? Trochę mi to nie pasuje, ze względu na przygotowane w obudowie otwory pod antenę od cc2531, ale to obejdę...

Edit: Po kilku kolejnych próbach nadal nie mogę uruchomić czystego obrazu z ssd. Działa tylko ten stary obraz zgrany z karty. O co kurde chodzi? Nie powinienem chyba mieszać, bo wątek o sprzęcie, ale nie wiem czy zakładać nowy temat.

OdpowiedzCytuj
Autor tematu Dodane : 23/11/2020 11:22 am
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2019, Donator 2K20
bartolomeo
(@bartolomeo)
Majster

Hej, nie widziałem wcześniej. Generalnie zakończyłem działania z sukcesem. Robiłem trochę na czuja sprawdzając po kolei każdą możliwą konfigurację i w końcu poszło. Przygotowałem wszystko od podstaw na karcie SD i dopiero wtedy jak miałem w pełni działający system to sobie go sklonowałem na dysk SSD. Działa na adapterze i przedłużaczu USB 1,5m, które wspominałem we wcześniejszym poście. Różnica w działaniu jest odczuwalna! Dzięki za porady wszystkim.

OdpowiedzCytuj
Autor tematu Dodane : 23/11/2020 5:28 pm
Udostępnij: