Forum Smart'ny Dom

Xiaomi + opehnab  

  RSS
lacky
(@lacky)
Początkujący

Dobry wieczór.

Posiadam Xiaomi Gatewaya z min. Motion Sensor który jest podłączony do openhaba. Problem polega na tym, że Motion sensor nie zawsze reaguje w openhab. Od kilku dni mam problem, że mimo skakania przed czujką cały czas jest OFF w openhab (dokladnie node red)  ale w Mi Home akcja czujki jest prawidłowo i co ciekawe nie zawsze tak jest bo czasem wszystko działa prawidłowo. Czyli problem gateway - opoenhab czy ktoś się już z tym spotkał ??

Cytuj
Dodane : 14/03/2019 7:31 pm
malygrzegorz
(@malygrzegorz)
Stażysta

mam tą bramkę chyba v2 i 2 czujniki temperatur, gniazdko, czujka drzwi i jak na razie cały czas wszystko przekazuje, mam też tą magiczną kostkę to ona czasem lagi ma ale ogólnie działa i wszystko do openhaba oczywiście tylko mam jeszcze poprzednią wersję 2.3

OdpowiedzCytuj
Dodane : 14/03/2019 10:29 pm
lacky
(@lacky)
Początkujący

Np. dzisiaj wykryto ruch XIaomi Gateway godz 6:29 -  Openhab 6:22 czyli już tego ruchu nie wykrył z 6:29 . Ale to nie ma reguły bo czasem jest dobrze. 

Najgorsze jest to, że to ma w kuchni zapalać światło i trudno mi tłumaczyć przed żoną, że to nie ja robię kawały.

Zastanawiam się nad inną bramką która będzie uniwersalna i nie będzie takich lagów.

OdpowiedzCytuj
Dodane : 15/03/2019 6:54 am
malygrzegorz
(@malygrzegorz)
Stażysta

a to załączanie światła masz pewnie w regułach zrobione to pytanie czy jakiegoś błędu w regułach nie masz ? 

OdpowiedzCytuj
Dodane : 19/03/2019 10:06 am
lacky
(@lacky)
Początkujący

Mam regułę zrobioną w node red. Ale to nie jest problem bo gdy motion sensor wykrywa ruch światełko się zapala. A często wykrywa w logach xiaomi widać a w openhab nie ma tego tylu wykryć co w xiaomi.

 

Kolega działa na Home Assistant i mówi że miał identycznie więc nasuwa wniosek, że może coś jest spaprane np. leci po UDP i jakieś pakiety gubi.

Zamówiłem już bramkę inną CC 2531 i zobaczymy jak z tym będzie gadać.

OdpowiedzCytuj
Dodane : 19/03/2019 10:15 am
matulekpl
(@matulekpl)
Stażysta

ale czemu to node red? a nie standardowe rules? rozumiem, że kwestia obrazkowa?

sprawdzałeś logi http://localhost:9001 ? Sprawdź tam czy wykrywa ruch i daje sygnał do openhab. Być może jednak jest to problem w regule napisanej z node red?

mam xiaomi gateway z 5 czujnikami , pomiarami temp. itp. i wszystko działa "w mgnieniu oka".

OdpowiedzCytuj
Dodane : 31/03/2019 11:52 pm
lacky
(@lacky)
Początkujący

Rzeczywiście jakiś to pomysł jest. Node red jest dla mnie wygodniejszy.

OdpowiedzCytuj
Dodane : 01/04/2019 10:59 am
matulekpl
(@matulekpl)
Stażysta

Na zagranicznym forum doczytałem, że aby uniknąć problemów w przesyłaniu sygnałów z gateway do OPENHAB trzeba:

Make sure they’re in the same network pool. For e.g my RPi was 1.1.1.111[1.1.1.0/24], however the gateway was in 2.2.2.64[2.2.2.0/24]

ale ni cholery nie wiem co to i jak to ugryźć;)

OdpowiedzCytuj
Dodane : 02/04/2019 9:08 pm
lacky
(@lacky)
Początkujący

Gdzieś znalazłem że xiaomi komunikuje się  protokołem UDP i tutaj leży problem. 

OdpowiedzCytuj
Dodane : 02/04/2019 10:09 pm
lukas121
(@lukas121)
Brygadzista Zasłużony dla Forum, Donator 2019

@matulekpl muszą mieć tą samą pulę adresów, podłączone do tego samego routera. UDP to standardowy protokół i to nie powinno być problemem.

OdpowiedzCytuj
Dodane : 02/04/2019 10:18 pm
lacky
(@lacky)
Początkujący

UDP standardowy ale TCP jest również standardowy i przy TCP być może by nie gubił. 

Rzeczywiscie opisane jest żeby był w tej samej podsieci,  ale taki standard ma chyba każdy a jeżeli nie to już wyższa szkoła żeby to spiać i jak ktoś to potrafi na bank sobie poradzi nie mówię o przekierowany portów.

OdpowiedzCytuj
Dodane : 03/04/2019 6:38 am
lacky
(@lacky)
Początkujący

Zigbee CC2531 + programator + kabelki otrzymałem, zaprogramowałem. Po pierwszych testach jestem bardzo zadowolony. Problemy się skończyły, wykrywa wszystko prawidłowo. Dodawanie urządzeń xiaomi prosta sprawa, nie dysponuję póki co innymi. Konfiguracja zaciągnięta z Home Assistant wszystko jest w configuration.yaml.

Bramka xiaomi odłączona.

OdpowiedzCytuj
Dodane : 07/04/2019 9:32 pm
maciej.krezlewicz
(@maciej-krezlewicz)
Młodzik

Witam

lacky gdzie kupowałeś Zigbee CC2531 + programator + kabelki 

OdpowiedzCytuj
Dodane : 21/07/2019 11:30 pm
maras
(@maras)
Majster Donator 2019

Dla jednej sztuki lepiej kupić na allegro.Chinczyki za programator chcą po 10$.
Też mam CC2531. Super spawa wszystkie czujniki zalania ładnie spięte po mqtt

OdpowiedzCytuj
Dodane : 22/07/2019 8:10 am
lacky
(@lacky)
Początkujący
Udostępnij:



Udostępnij
  • 1
    Share

Proszę Zaloguj Się lub Zarejestruj