AFE nie działa prze...
 
Powiadomienia
Wyczyść wszystko

Pomoc AFE nie działa prze mqtt z OH3

Strona 2 / 3
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

Hey

na pewno zaznaczyłeś - sprawdź dostępności serwera, na poniższym?

OH, czy włączony, czy nie to tutaj nie ma raczej znaczenia, co najwyżej MQTT Serwer. 

image
OdpowiedzCytuj
Dodane : 01/12/2021 7:49 pm
laren0
(@laren0)
Stażysta

@adrian 

Faktycznie nie zaznaczyłem tego. Po zaznaczeniu tak jakby te diody rzadziej się załączały na sonoffach ale na 2-3 sekundy podczas migania niebieskiej diody zawiesza się tak że nie można sterować. Jednak to nie rozwiązało problemów z rozłączaniem się z OH poszczególnych sonoffów. w logach widzę że raz na 4-6 godziń któryś item od podłączenia sonoffa do mqtt wyłącza się i włącza na ułamek sekundy. Czasem przy tym załączy się któryś z kanałów.

 W logach bardzo dużo wyskakuje kotłowniaMotion ponieważ zapomniałem wyłączyć pliki konfiguracyjne a z tym widzę że też są problemy ponieważ aż tak gęstego ruchu tam nie mam.

OdpowiedzCytuj
Autor tematu Dodane : 04/12/2021 9:32 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

@laren0 hey, jak pisałem wcześniej rozwiązujmy jeden problem po drugim, bo tak to będzie skakać po tematach i się nie dogadamy.

czy po tych 2-3 sekundach po tym miganiu diody możesz sterować?

pozdr

OdpowiedzCytuj
Dodane : 04/12/2021 11:45 pm
laren0
(@laren0)
Stażysta

Tak mogę sterować po tych 2-3sekundach

OdpowiedzCytuj
Autor tematu Dodane : 05/12/2021 9:17 am
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

Ok, gitara; 

ten czas 2-3 sekundy to czas jaki ustawiasz w tym oknie: jak długo czekać na odpowiedź serwera. Możesz go ciut zmniejszyć, ale jeśli za bardzo to może mieć trudność z połączeniem się z MQTT Brokerem.

Takie zacięcie o czasie tam ustawiony będzie tylko 1 raz po tym jak straci dostęp MQTT Brokera 

Więcej z tego się nie wyciśnie. 

Teraz to rozłączanie się

To rozłączanie się to nie wygląda na rozłączanie się od OH3. Wygląda bardziej, jakby urządzenie się resetowało. 

Mam pytanie, czy to występuje w jednym, we wszystkich urządzeniach?

 

 

 

OdpowiedzCytuj
Dodane : 05/12/2021 11:27 am
laren0
(@laren0)
Stażysta

@adrian 

We wszystkich urządzeniach. Jednych częściej w drugich rzadziej nie mogłem znaleźć żadnych żależności czemu tak się dzieje.

W urządzeniach niejednokrotnie przywracałem ustawienia początkowe ale to nie rozwiązywało tego resetowania

OdpowiedzCytuj
Autor tematu Dodane : 05/12/2021 12:36 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

Możesz przysłać pełna konfigurację jednego z nich np. tego co mam Item : ZasilanieSonoffA2

  1. konfiguracja WiFi
  2. konfiguracja MQTT Brokere
  3. Wszystkie przekaźniki
  4. Wszystkie przyciski

Przy okazji widział w któryś z Twoich screenshot'ów, że w MQTT brokerze wpisujesz adres  do brokera: localhost i IP Adres. Wpisz jedne najlepiej: IP adres. Nie wpisuj localhost i adres.

pzdr.a 

OdpowiedzCytuj
Dodane : 05/12/2021 10:47 pm
laren0
(@laren0)
Stażysta
urzadzenie
wifi1
wifi2
mqtt
led
przekaznik1
przekaznik2
przekaznik3
przekaznik4
przycisk1
przycisk2
przycisk3
przycisk4
Led2
OdpowiedzCytuj
Autor tematu Dodane : 06/12/2021 8:07 pm
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20

Czy możesz w jednym z modułów zmienić konfig Brokera na taki ?

1017 mqtt
OdpowiedzCytuj
Dodane : 06/12/2021 8:33 pm
laren0
(@laren0)
Stażysta

usunąłem "localhost" i zwiększyłem do 4000 ms czas oczekiwania

Zrobiłem to na 2 kolejnych sonoffaw które mam na stole (nie w rozdzielni). Testuje.

OdpowiedzCytuj
Autor tematu Dodane : 06/12/2021 11:47 pm
laren0
(@laren0)
Stażysta

Zostawiłem na noc podpięte 2 sonoffy do sieci i OH z tym że dodałem regułę abym otrzymywał informację w aplikacji jeśli nastąpi rozłączenie i połączenie z którymś z urządzeń. W ciągu 7 godzin około 12 powiadomień że się resowałały. W załączniku logi, do około 00:32 jeszcze sam przełączałem później pozostawiłem samopas.

 

OdpowiedzCytuj
Autor tematu Dodane : 07/12/2021 7:31 am
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

@laren0 podeślij jeszcze swoje itemy żeby wiedzieć które to są przełączniki które lwt, które są z jednego urządzenia

konfig przekaźników, przycisków przydałby się

pzdr.

OdpowiedzCytuj
Dodane : 07/12/2021 9:48 pm
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20

Nie znam OH absolutnie , ale czy konfig przycisku systemowego ustawiony na czułość 30 nie robi złej roboty ?

 

OdpowiedzCytuj
Dodane : 08/12/2021 12:27 am
laren0
(@laren0)
Stażysta

ITEMY od oświetlenia i struktury domu

 

Things:

konfiguracja przekaźników i przycisków z AFE na sonoffie powyżej w poście ze screenami.

@isom te 30 mam ustawione tylko po to ponieważ mam dzwonkowe przyciski i jak było 50 to czasami mi nie łapały, ta czułość chyba raczej nie wpływa na włączanie trybu konfiguracyjnego ponieważ trzeba to zrobić dłużej jak chyba 5 sekund.

obecnie 6 sonoffów które były widoczne na filmikach znajdują się w 2 domu i tam póki nie działa sieć do której są podpięte to wszystko chodzi.

To co powyżej przesłałem logi z 07-12-2021 to są z 2 kolejnych sonoffów które mam nadprogramowo na razie i one mają taką samą konfiguracje jak jedne z 2 z tej rozdzielni ale one wraz z OH teraz działają w 1 domu i są podpięte do innego routera tylko z tą samą nazwą SSID. I z tak podpiętymi 2 sonoffami i OH3 działa testowo od wczoraj - poniżej logi z dzisiejszego dnia - powyłączałem większość thingów i iteamów tak aby nie zaciemniały niepotrzebnymi obecnie logami:

Nikt na forum nie używa sonoffów 4ch z OH3 i AFE ? że tylko u mnie to tak nieprzewidywalnie razem działa?

 

OdpowiedzCytuj
Autor tematu Dodane : 08/12/2021 12:56 am
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20

Ja nie czepiam się czasu tylko sonoff4ch to złożona konstrukcja i mogą występować dziwne zjawiska , przypuszczam że problem leży po stronie serwera i współpracy z nim , ale sorki gdyby to był domoticz to służę pomocą 

OdpowiedzCytuj
Dodane : 08/12/2021 1:21 pm
laren0
(@laren0)
Stażysta

Wczoraj przełamałem się i na jednym z dwóch sonoffow które ostatnio podsyłałem logi I się resetowały po podłączeniu do wifi i  OH3, wgrałem tasmote skonfigurowałem i w OH3 poprawiłem tematy w istniejących itemach. I o dziwo od 15 godzin pracują oba sonoffy i żaden się jeszcze nie zresetował (ani samo się nie załączyłao lub wyłaczyło) ani ten na tasmocie ani ten na AFE 3.1.0.

OdpowiedzCytuj
Autor tematu Dodane : 09/12/2021 3:06 pm
laren0
(@laren0)
Stażysta

Jednak AFE w końcu się wyłączył i włączył. Bawię się mqtt Explorerem i po dłużej chwili przełączania zauważyłem że pojawił się dziwny temat - a2/switch06/cmd/state=close

image

 

Na pewno odpowiada on za Sonoffa z AFE  (w tym przypadku opisany jest jako sonoffa2) i gdy stan tego tematu "a2/switch06/cmd/state" jest na "close" to na sonoffie nie działają 1 i 2 przycisk gdy opublikuje wiadomość dla tego tematu jako" open" to odblokowują się przełączniki 1 i 2 i mogę sterować. Pytanie skąd się wziął ten dodatkowy temat do obsługi "sonoffa2" skoro w webUI AFE nigdzie nie mam takiego tematu wpisanego. Mało tego znalazłem prawidłowość że gdy ten temat się pojawił z opcją "close" to z OH3 dostałem alert że stracił kontakt z "ZasilanieSonoffA2":

image
image
OdpowiedzCytuj
Autor tematu Dodane : 09/12/2021 11:41 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

bardzo, bardzo dziwne 

a nie ma na jakimś przycisku w AFE tematu MQTT ?

Mam jednego 4CH - zainstaluje w nim AFE w weekend i spróbuje zareplikować 

Nie masz jakieś reguły która mogłaby coś wysyłać do niego ? zamiast właśnie On/Off to jakieś open,close?

pzdr.a

OdpowiedzCytuj
Dodane : 09/12/2021 11:52 pm
laren0
(@laren0)
Stażysta

@adrian 

Nie ma innych tematów jak tematy przekaźników i temat LWT

Wszystkie sonoffy I AFE mają dokładnie takie same dane wprowadzone a tematy różnią się tylko nazwami urządzenia (A1-A7) i switche są od (switch01 - switch28).

OdpowiedzCytuj
Autor tematu Dodane : 10/12/2021 7:22 am
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

AFE moze wysyalc teamty open i closed (nie close) ze switch'a właśnie

NIe masz jakiś reguł?

OdpowiedzCytuj
Dodane : 10/12/2021 8:13 am
Strona 2 / 3
Udostępnij: