Notifications
Clear all

Sonoff smart switch problem z podłączeniem do aplikacji  

Strona 1 / 3
  RSS
Przemek
(@przemek)
Młodzik

Witaj,

Przypadkiem znalazłem się na Twojej stronie i widzę że poziom jest dośc wysoki, dlatego nie wiem czy uzyskam odpowiedź na tak banalne pytanie.

Nabyłem 3 przełączniki sonoff (identyczne z tymi, które opisujesz z czujnikiem temperatury - te z czarną czcionką na obudowie). Sciągnąłem apkę na androida w celu zarejestrowania się i podpięcia urządzenia. Urzadzenie przelaczone w tryb parowania (szybko mrugająca dioda) w eweLink wybieram sieć domową i chcę parować urządzenie. Tu znajduje sieć Wifi ITEAD-10005d89 po czym wywala błąd połączenia WIFI.

Acha, wcześniej dodałem statyczny IP w telefonie dla sieci ITEAD 192.168.4.1 i haslo 12345678 aby wogóle choć na chwile podłączył sie do tej sieci.

Oczywiscie w eweLink probowałem zamiast swojej domowej sieci podłączyć od razu ITEAD ale bez skutku.

Czy wiesz jaka może być przyczyna?

Z góry dziękuję za pomoc.

Cytuj
Dodane : 08/02/2017 12:25 am
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

cześć, z Twojego opisu i jak sobie to zwizualizowałem to chyba nie tak, podaje krok po kroku, ale tak z głowy:

  • w telefonie jesteś podłączony do sieci WiFi w domu
  • ściągasz aplikacje eWelink na Androida
  • rejestrujesz konto
  • wciskasz przycisk plus w aplikacji eWelink, żeby dodać nowe urządzenie
  • w Sonoff wciskasz na o 5 sek przycisk żeby dioda zaczęła szybko mrugać
  • w telefonie przechodzisz do wyszukiwania WiFi i podłączasz się to tej ITEAD z hasłem 12345678
  • jak się podłączysz telefonem do sieci WiFi ITEAD*** to wracasz do aplikacji EweLink
  • wciskasz chyba przycisk Dalej, aż pojawi się taki formularz do wprowadzenia informacji o sieci WiFI
  • W tym formularz wpisujesz parametry sieci WiFi u Ciebie w domu (nie te ITEAD)
  • Wciskasz przycisk Dalej (chyba)
  • [Co się dzieje] Konfiguracja twojej sieci WiFi w domu jest zapisana do przełącznika Sonoff.
  • Jak konfiguracja zostanie wysłana do przełącznika powinno wyskoczyć okienko, żeby jeszcze nadać nazwę temu przełącznikowi Sonoff

W żadnym momencie konfiguracji nie ma potrzeby do nadawania statycznego adresu IP do Sonoff

W tym filmiku pokazuje (od ok 6minuty), jak dodać Sonoff'a do eWelink

daj znać, czy zadziałało

OdpowiedzCytuj
Dodane : 08/02/2017 9:32 am
Przemek
(@przemek)
Młodzik

Jest tak jak opisałeś, z tym, ze jeśli nie wprowadzę IP statycznego to nie ma szans aby połączyć się z adresem przydzielonym przez DHCP. Po prostu każda próba konczy się fiaskiem.

Jeśli robię tak jak opisujesz (przy dynamicznym IP) reczywiście na chwilę łączy się z ITEAD a potem pojawia się błąd:

Pair Fail

Communication process error, please operate by following the instructions

I tak za każdym razem.

OdpowiedzCytuj
Dodane : 08/02/2017 11:10 am
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

no, nie jest to typowe zachowanie.

a ten IP adres 192.168.4.1 w jakie "pole" w telefonie wpisujesz?

powinieneś mieć adres IP, bramkę, dns itp

OdpowiedzCytuj
Dodane : 08/02/2017 12:08 pm
Przemek
(@przemek)
Młodzik

wpisalem tylko IP address.

Inne parametry zostały domyslne.

Czyli brama 192.168.4.1

dns 8.8.8.8 i 8.8.4.4

Po kliknieciu połącz - jestem podpięty przez kilka sekund a potem rozłącza.

OdpowiedzCytuj
Dodane : 08/02/2017 2:34 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

Adres IP nie moze byc 192.168.4.1 w telefonie bo to adres Sonoff wiec moja sugestia to wpisać np.:

  • adres IP: 192.168.4.2
  • bramka: 192.168.4.1
  • maska podsieci: 255.255.255.0
  • dns: 192.168.4.1

aczkolwiek lepsze byłoby sprawdzenie, czemu nie można podłączyć się do Sonoff przez WiFi z DHCP

A czy z komputera da się podłączyć przez DHCP do Sonoff?

OdpowiedzCytuj
Dodane : 08/02/2017 2:43 pm
Przemek
(@przemek)
Młodzik

Wyjąłem 3 -cie pudełko z nowym sonoff. Wszystko wg instrukcji. Bez dodawania statycznych adresów.

SPrawdziłem przez komputer jaki adres dostaje moj komputer i jaki jest IP bramki.

Po podłączeniu do sieci ITEAD...

IP 10.10.7.2

maska 255.255.255.0

Bramka 10.10.7.1.

Niestety nie udało mi się także podłączyc przez ewelink. Dziwna sprawa.

OdpowiedzCytuj
Dodane : 08/02/2017 3:15 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

A czy telefon nie próbuje łączyć się po sieci 5Ghz do tego Sonoff ? nie wiem co za telefon

Sonoffy chodzą tylko na 2.4GHZ

OdpowiedzCytuj
Dodane : 08/02/2017 3:26 pm
Przemek
(@przemek)
Młodzik

Jest to samsung s6 Edge a co do czestotliwości to niestety nie mam takich informacji. Czy możliwe aby 3 urzadzenia nie chcialy sie podlaczyc. To pytanie najbardziej mnie irytuje

OdpowiedzCytuj
Dodane : 08/02/2017 3:30 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

3 urządzenia rozumiem sonoffy?

bo komp podłaczył sie, bo dostal IP'iki

OdpowiedzCytuj
Dodane : 08/02/2017 3:33 pm
Przemek
(@przemek)
Młodzik

tak, chodzilo mi o sonoffy.  Komputer podłączył się do tej sieci na okres kiedy mruga dioda, lecz nie jest w stanie nawet wejsc na adres http://192.168.4.1 czyli adres bramki w chwili kiedy ustawiam statyczny IP adres.

OdpowiedzCytuj
Dodane : 08/02/2017 3:45 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

tutaj znalazłem taka ciekawostkę odnośnie s6, ze rozłącza się z WiFI jeśli dane WiFi nie ma podłączenia do internetu. Tutaj będzie taka sytuacja. Podłącza się do sieci ITEAD*** - ta sieć nie ma dostępu do Internetu więc się rozłącza.

Trzeba wyłączyć opcję Smart Switch - może to?????

Poniżej opis w języku Language,

This is due to a feature called ‘Smart Switch’ from Samsung. When the Galaxy S6 detects that there is no internet connectivity to the Wi-Fi network it is connected to, it automatically disconnects and switches back to mobile data. This feature does not play well with certain internet connections, which leads to the handset disconnecting from Wi-Fi networks with a working internet connection

The problem can be solved by simply disabling Smart Switch, which can be done by going into Settings -> Wi-Fi -> Smart Switch and then selecting the ‘Off’ option

OdpowiedzCytuj
Dodane : 08/02/2017 3:49 pm
Przemek
(@przemek)
Młodzik

Wlaśnie wykonałem ta sama operację na Iphone 6. Ewidentnie zrywa połączenie przy parowaniu.

Tu jest napisane:

Blad komunikacji Sprawdz nastepujaca konfigurację

a opuszczono stan parowania urzadzenia

b Nie otwarto ustawien wifi

Zaznaczę że adres przypisal mu 10.10.7.2 a dns 10.10.7.1, czyli tak samo jak bramę

Co do s6 edge, ta opcja byla wylaczona, ale przetestowalem ja takze n wlaczonej i jest tak samo

OdpowiedzCytuj
Dodane : 08/02/2017 4:03 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

A jak działa jak się wyłączy ten smart Search w S6?

  • sugeruje może jeszcze wyłączyć data transfer
  • w iPhone czasami tez mi rozłączał WiFi, ale jakoś na ogół szło.

jeszcze informacyjnie ten tryb parowania rozłącza się po jakimś czasie w przycisku Sonoff - więc trzeba robić kroki w miarę szybko.

tylko qrcze z Iphona powinno pójść.

OdpowiedzCytuj
Dodane : 08/02/2017 4:11 pm
Przemek
(@przemek)
Młodzik

jesli funkcja jest wlaczona, urzadzenie automatycznie zostanie podlaczone z siecia komorkowa gdy wifi bedzie niestabilne.

Data transfer jest wylaczone non-stop.

No nic, dzięki za chęci i tak dużo czasu poswieciłeś na ten problem.

Urzadzenia nie działają i napiszę do Aliexpress o zwrot kosztów.

pozdrawiam

OdpowiedzCytuj
Dodane : 08/02/2017 4:17 pm
adrian polubień
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

Jeśli Aliexpress zwróci koszty i nie będziesz potrzeby odsyłać to ja te 3 mogę odkupić za 40 🙂

OdpowiedzCytuj
Dodane : 08/02/2017 6:46 pm
Marek Pal
(@fb_-marekpal)
Nowy

Przed polaczeniem z Sonoff, poczekaj az polaczy Ci sie z Twojá siecia wifi, kliknij w ustawienia i wybierz opcje zapomnij ta siec , czy cos podobnego, mialem podobny problem, Troche czasu zajelo zanim to ogarnalem 😉 Wlasnie taka podobna akcja, Musialem usunac wszystkie sieci z ktorymi mi sie laczyl telefon 😉 i pozniej ruszylo.

OdpowiedzCytuj
Dodane : 08/02/2017 11:23 pm
adrian polubień
Przemek
(@przemek)
Młodzik

Cześć ponownie.

W końcu udało się podłączyć do przełącznika. Problemem były zbyt duże zabezpieczenia mojej sieci WIFI, przez które switch nie wiedział jak się skomunikować z moim routerem. Przełączyłem z WPA2-->WPA i z TKIP -->AES i działa.

OdpowiedzCytuj
Dodane : 10/02/2017 4:48 pm
adrian polubień
manfred
(@manfred)
Młodzik

Trzeci dzień próby parowania z sonoff. Ciągle wyskakuje błąd parowania. Już sam nie wiem jak to zrobić.

OdpowiedzCytuj
Dodane : 22/02/2017 8:50 pm
manfred polubień
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony
Dodane przez: manfred

Trzeci dzień próby parowania z sonoff. Ciągle wyskakuje błąd parowania. Już sam nie wiem jak to zrobić.

Jakie oprogramowanie jest w Sonoff?

OdpowiedzCytuj
Dodane : 22/02/2017 9:47 pm
Strona 1 / 3
Udostępnij: