Smarticz na RPi 3+ ...
 
Powiadomienia
Wyczyść wszystko

Uwaga: Muszę przeprowadzić modernizację oprogramowania na serwerze, a w czarnym scenariuszu oznacza przeinstalowanie całego serwera na co muszę się przygotować.

Planuję to zrobić w ten weekend (25-26 Wrzesień). Prace będa wyglądały tak, że

- musze przygotować drugi zapasowy serwer i przenieść na niego strony: Smart'ny Dom, Forum, AFE

- przeprowadzić modernizację, która zajmie kilka godzin

- przenieść ponownie strony na modernizowany serwer

W tym czasie mogą występować braki w dostępie do strony lub mogą występować problemy z działaniem strony (wydajność, błędy) itp za co z góry przepraszam

Pozdrawiam, Admin

Smarticz Smarticz na RPi 3+ wiesza się codziennie

Bartek_F
(@bartek_f)
Majster

Mam od kilkunastu dni problem z moim RPi 3+ z Smarticzem na dysku SSD plus wpięty w USB moduł pod Zigbee. Mianowicie codziennie pod wieczór jak sobie chcę światło zaświecić z domoticza to okazuje się, że system wisi. Nie da się ani odpalić żadnej z aplikacji Smarticza, ani połączyć przez SSH, ani puścić pinga w sieci lokalnej. Czasem bywa tak, że pomaga dopiero drugi reset. Mimo tego jak urządzenie zresetuję (odcięcie zasilania), to po powrocie wchodzę np w Domoticzu w statystyki temperatury choćby czujnika zigbee czy czujnika temperatury z płyty RPi, to pokazuje mi statystyki bez dziury. Dodam że temperatura na RPi to cały czas 56-58 st C. Podpowiedzcie gdzie mogę znaleźć jakieś logi albo jak inaczej mogę sprawdzić co i w którym momencie wywala mi rasbiana. Codzienny reset urządzenia jest trochę upierdliwy.

Cytuj
Autor tematu Dodane : 24/07/2021 1:57 pm
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20

@bartek_f z tego co piszesz to szukanie w logach nic nie da , czepiać się domoticza też nie ma co , bardziej bym się skupił na zasilaniu dysku SSD bo skoro czasem dopiero drugi reset podnosi system to może być że dysk nie pracuje stabilnie.

Jeśli zasilasz dysk z portu USB to warto rozważyć zakup aktywnego huba USB i zasilić z niego dysk . 

Temperatury na poziomie bliskim 60 st to nie jest optymalnie, ale też nie krytycznie, chociaż warto dołożyć lub zmienić chłodzenie.

 

OdpowiedzCytuj
Dodane : 24/07/2021 9:50 pm
Bartek_F polubień
pawell32
(@pawell32)
Brygadzista

j.w.

miałem tak samo tzn. ssd + 2 dongle. Zasilanie zysku rozwiązało problem.

OdpowiedzCytuj
Dodane : 26/07/2021 9:40 am
Bartek_F polubień
Bartek_F
(@bartek_f)
Majster

Dzięki za pomoc, chociaż zdziwiło mnie to, że zazwyczaj to się wywala o podobnych porach (pod wieczór) i myślałem, że to może jakaś konkretna akcja wywala. Możecie polecić jakieś rozwiązanie z tym zasilaniem dysku?

OdpowiedzCytuj
Autor tematu Dodane : 26/07/2021 11:56 am
pawell32
(@pawell32)
Brygadzista
piotras78
(@piotras78)
Stażysta

Mam to samo u siebie i na RPi 3 i na RPi 4. System działał stabilnie od jakiś dwóch miesięcy a ostatnio codziennie reset. W miedzy czasie wymieniłem dongla z-wave z-stick gen5 na z-stick gen 5+ bo tylko on działa bez HUBa na RPi 4. Dodatkowo w systemie mam jeszcze ConBeeII. Dzisiaj wyłączyłem w Domoticzu z-sticka (siedzi nadal w usb) i jak do tej pory system działa - wczesniej pracował 2-3 h zaczynał sie restetowac po czym następował brak dostępu przez www - można było się tylko zalogowac przez ssh - system nie realizował skryptów. Nie mam dostępu do urządzeń z-wave ale sprawdzę czy tez padnie po jakimś czasie

OdpowiedzCytuj
Dodane : 27/07/2021 11:09 pm
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20

@piotras78 u Ciebie to nie to samo . Skoro masz dostęp przez SSH to znaczy, że nie pada cały system a tylko Domoticz. Przyczyną wielokrotnych resetów jest na 99% monit , to broń obosieczna. Często przy nieoczekiwanym błędzie taki restart pomaga i system dalej pracuje , jednak gdy występuje problem np ze sprzętem, tu z-wave , monit próbuje uruchomić domoticza kilka razy , następnie robi reboot całego systemu.

Nie korzystam  z urządzeń z-wave ale wiem że do ostatniej stabilnej wersji domoticz były robione poprawki dotyczące z-wave wydane w wersji beta, więc warto zrobić kopię katalogu domoticz w obecnej wersji , aktualizować do wersji beta i sprawdzić czy to nie pomoże.

Jeśli nic to nie da zawsze można przywrócić system z kopi 

 

OdpowiedzCytuj
Dodane : 28/07/2021 8:40 am
piotras78
(@piotras78)
Stażysta

@isom Tak wiem że za resety odpowiada u mnie monit. Znalazłem na zagranicznych forach informację że jest/był właśnie jakiś problem z z-wave. Dodatkowo sam z-stick gen 5 nie chce chodzić z RPi 4 bo ma jakąś niezgodność z USB - jedynie przez dodatkowy HUB ale u mnie i tak były z tym problemy. Kupiłem więc z-stick gen5+ i niby działa ale tez nie rusza od ręki tak jak ten poprzedni na RPi3 (czasami zgubi urzadzenia ale pomaga odpalenie go na 3 - wtedy wracają). Generalnie z RPi3 było mniej problemów niż z 4

OdpowiedzCytuj
Dodane : 28/07/2021 7:36 pm
Udostępnij: