Forum Smart'ny Dom

Sonoff Basic - AFE - T0 (1.4.0) / T2 (1.2.2)  

  RSS
marlon
(@marlon)
Majster

Witam,

Mam problem z Sonoffem Basic, wgralem AFE T0 w wersji 1.4.0 (8266) i podlaczylem dodatkowy zewnetrzny wlacznik do niego. Oczywiscie dodalem rezystor oraz kondensator wedlug rysunku. Po zalaczeniu zasilania, sonoff laczy sie z siecia domowa, mozna go sterowac 2 czasami 3 razy po czym resetuje swoje ustawienia do zera. Budzi sie ponownie juz z IP 192.168.5.1.

Probowalem wylaczyc calkowicie wlacznik ale bez roznicy, te same zachowanie.

Wgralem do niego sprawdzony soft T2 1.2.2 8266 (czujnik DHT wylaczony) ale znowu to samo.

Probowalem wgrywac czyste oprogramowania a potem T2 do niego bez zmian.

Podejrzewam ze mam jakis wadliwa sztuke wiec sprobuje zrobic to samo na nowym, zobaczymy czy problem ustapia.

Czy moze o czyms zapomnialem, co nalezalo by sprawdzic ?

Cytuj
Dodane : 23/02/2019 4:06 pm
marlon
(@marlon)
Majster

Na dodatek wlasnie zauwazylem ze w momencie kiedy moj nowy sonoff wysypuje ustawienia, trace temperature z drugiego sonoffa (pokazuje -5C) do ktorego jest podpiety DHT22 (ten ma T2 1.3.3). Wtedy potrzebny jest twardy restart tego sonoffa (z czujnikiem DHT) poprzez odlaczenie zasilania od niego na bezpieczniku. Probowalem robic restart sonoffa przez http , przy wychodzeniu z trybu konfiguracji robi zawsze restart urzadzenia ale tu w tym wypadku to nie wystarcza.

Nie bardzo wiem dlaczego, mozliwe ze mam jakies dwie wadliwe sztuki tutaj. Zalaczam schemat prowizoryczny polaczen.

Moze to wina zaklucen ? Czy ktos spotkal sie z podobnymi problemami ?

 

OdpowiedzCytuj
Dodane : 23/02/2019 4:53 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

nie ustawiasz przypadkiem tego przycisku zewnętrznego jako systemowy?

 

OH2+AFE

OdpowiedzCytuj
Dodane : 23/02/2019 7:32 pm
marlon
(@marlon)
Majster

@Adrian Nie, wylaczylem teraz nawet wlacznik zewnetrzny calkowicie. Problem pojawia sie za kazdym razem, po ostatnim wpisaniu ustawien wytrzymal 4 zalaczenia. Pomiedzy zalaczeniami przekaznika trzymam dosc dlugie odstepy.

Rowniez nie wiem dlaczego drugi sonoff traci odczyt temperatury za kazdym razem kiedy pierwszy sie wysypie - wskazuje wtedy -5C i wtedy musze odlaczyc go od zasilania i powtornie wlaczyc. Oba sa ze wspolnego zasilania przez oddzielne bezpieczniki.

OdpowiedzCytuj
Dodane : 23/02/2019 7:56 pm
isom
 isom
(@isom)
Szef Moderator Zasłużony dla Forum, Donator 2019

jak daleko od siebie są te sonoff-y ? Słyszałem, że jak są obok siebie to czasem jeden zakłóca drugiego , ja nie miałem takiego przypadku , ale warto to sprawdzić

OdpowiedzCytuj
Dodane : 23/02/2019 8:25 pm
marlon
(@marlon)
Majster

Odleglosc to 70 cm, czyli nie tak bardzo blisko.

10kQ mam pomiedzy 3.3V i GPIO14. Kondensator 100nF siedzi pomiedzy GND i GPIO14 tak ze nie powinno tutaj byc problemow.

Mam jeszcze jeden egzemplarz, odpale swierzego sonoffa z tym samym softem zobaczymy czy objawy sie powtorza.

OdpowiedzCytuj
Dodane : 23/02/2019 9:25 pm
marlon
(@marlon)
Majster

Tak jak pisalem odpalilem nowego Sonoffa. Wgralem T2 1.4.0. Podlaczylem wlacznik zewnetrzny na GPIO14. Podmienilem Sonoffy w puszce. I pojawila sie ta sama sytuacja, znowu wysypuje soft . Odlaczylem calkowicie wlacznik fizycznie w kontakcie i rowniez w sofcie. I probuje dalej ale pomysly juz mi sie wyczerpuja.

@Adrian Z punktu widzenia firmware czy jest to mozliwe zeby urzadenie wyrzucilo konfiguracje. Czy w firware jest jakas kondycja ktora mogla by wywolac takie zachowanie ?

Sonoff steruje wiatrakiem w lazience, moc pobierana to tylko 13W. Przed podmiana Sonoffow testowalem nowego na stole bez obciazenia chyba przynajmniej 30 zalaczen i nie bylo zadnego problem.

OdpowiedzCytuj
Dodane : 23/02/2019 10:50 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

W oprogramowaniu konfiguracje może skasować tylko  jak jest ustawiony przycisk systemowy i zostanie wcisniety na 30sek 

  • nie mazsz moze jakos podwójnie skonfigurowanego tego samego GPIO dla LED, Przekaźnik, Przycisk ?
  • Podeslij moze screeny z konfiguracji: Urzadzenie, Przekaznik, LED, Przycisk, Czujnik temperatury

OH2+AFE

OdpowiedzCytuj
Dodane : 23/02/2019 11:17 pm
isom
 isom
(@isom)
Szef Moderator Zasłużony dla Forum, Donator 2019

@marlon skoro na stole było ok to może sam wiatrak a raczej jego silnik wprowadza zakłócenia , ktoś już miał podobnie z pompą od CO . Możesz spróbować wysterować sonoff-em cewkę jakiegoś przekaźnika lub stycznika 230V a wiatrak podłączyć przez  ten stycznik

OdpowiedzCytuj
Dodane : 23/02/2019 11:18 pm
marlon
(@marlon)
Majster

Zalaczam ustawienia do wgladu. Przycisk i DHT jest calkowicie wylaczony w tej chwili.

 
 
@isom Byc moze masz racje z tymi zakluceniami, na stole dzialalo ok wiec warto to sprawdzic. Polecisz jakas cewke na 230V malych rozmiarow, Foteq mi sie do tej puszki juz nie zmiesci. 
OdpowiedzCytuj
Dodane : 23/02/2019 11:29 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

Konfiguracja wyglada Ok- bardzo dziwny przypadek. 

Rozumiem ze jak odłączysz ten wiatrak to jest Ok ?

OH2+AFE

OdpowiedzCytuj
Dodane : 23/02/2019 11:52 pm
marlon
(@marlon)
Majster

Wyglada na to ze tak. Sprobuje przez jakac cewke przekaznika. Bede musial cos znalezc malych rozmiarow bo miejsca bardzo bardzo niewiele - polecicie cos godnego uwagi na 230V. Ten wiatrak pobiera tylko 13W, jakby trzeba bylo kiedys wymienic na inny to nie wiecej niz 50W.

OdpowiedzCytuj
Dodane : 24/02/2019 12:05 am
isom
 isom
(@isom)
Szef Moderator Zasłużony dla Forum, Donator 2019

@marlon jesli chcesz mały przekaźnik to polecam taki https://www.tme.eu/pl/details/rm84-2012-35-5230/przekazniki-elektromagn-miniaturowe/relpol/

Możesz też za grosze zbudować sobie układ jak na schemacie poniżej i wysterować ten wentylator z dowolnego GPIO tego sonoff-a , wtedy oryginalny przekaźnik zostanie na zapas , lub zwiększając wartość rezystora na wejściu  możesz dolutować się do cewki oryginalnego przekaźnika 

OdpowiedzCytuj
Dodane : 24/02/2019 12:41 pm
marlon
(@marlon)
Majster

@isom dzięki za wskazówki, wracam do domu w Piątek to sprawdzę.

W Sonoffie dokładam rezystor 10k pomiędzy 3.3V i GPIO14 jak również kondensator 100mikro GPIO14-GND. Może zmiana tego rezystora na mniejszy by coś pomogła ?

OdpowiedzCytuj
Dodane : 28/02/2019 11:41 pm
isom
 isom
(@isom)
Szef Moderator Zasłużony dla Forum, Donator 2019

@marlon Ja myślę że to zakłócenie nie wchodzi po stronie niskiego napięcia ( przycisk) tylko po sieci 230V , a kondensator to 100 nano a nie mikro. 

OdpowiedzCytuj
Dodane : 01/03/2019 8:20 am
marlon
(@marlon)
Majster

Dzięki @isom. Kondensator 100nF masz racje. 

OdpowiedzCytuj
Dodane : 01/03/2019 1:56 pm
marlon
(@marlon)
Majster

@isom 

Jak wczesniej wspominalem mam drugiego Sonoffa z DHT22 w lazience do sterowanie farelka na zamontowana na scianie. 

Nie jestem na 100% przekonany czy ten problem związany jest z zakłóceniami czy. Oś innego się dzieje ale co kilka dni tracę odczyt temperatury, wskazanie pokazuje -5C. Wtedy potrzebny jest restart Sonoffa poprzez odcięcie zasilania. Po restarcie problem ustępuje. 

Co moze być przyczyna? Pomiędzy nóżkami DHT22 mam 10k rezystor zamontowany. 

Czt to może być jakiś wadliwy cxujnik czy problem z  Sonoffem ?

OdpowiedzCytuj
Dodane : 03/03/2019 12:32 am
isom
 isom
(@isom)
Szef Moderator Zasłużony dla Forum, Donator 2019

@marlon jeżeli wiesza się tylko odczyt temp , a cała reszta działa to sprawdził bym ten czujnik na stole nawet z tym samym sonoffem , ale bez farelki ,albo jeżeli to strategiczne ogrzewanie łazienki to odpiąć tego DHT od sonoffa i podłączyć do jakiegoś innego modułu chociaż tymczasowo. Jak dorobisz lub dokupisz przekaźnik , to weź na wszelki wypadek dwa , jak się nie przyda teraz to na pewno przy innym projekcie wykorzystasz

OdpowiedzCytuj
Dodane : 03/03/2019 12:30 pm
marlon
(@marlon)
Majster

@isom  Dzieki za info. Przekazniki mi jeszcze nie dotartly, mam nadzieje ze listonosz nie zgubil przesylki  

Pisales wczesniej o zwiekszeniu wartosci rezystora na wejsciu ze mozna dolutowac sie do cewki oryginalnego przekaznika. Masz moze jakas fotke z sonoffa abym mogl to zobaczyc ? Jaki rezystor mozna bylo by tam wykorzystac ? Ten Sonoff co steruje farelka ciagle wywala mi konfiguracje, srednio co poltora dnia co oczywiscie jest bardzo denerwujace. Czasami zdarza sie to przy probie zalaczenia farelki , czasami przy probie jej wylaczenia. Wtedy Sonoff resetuje ustawienia i budzi sie z adresem IP 192.168.5.1. Czasami jakies dane czastkowe zostaja jak w zalaczniku.

OdpowiedzCytuj
Dodane : 15/03/2019 8:25 pm
isom
 isom
(@isom)
Szef Moderator Zasłużony dla Forum, Donator 2019

@marlon pisząc o większym rezystorze miałem na myśli schemat sterowania triakiem i tam rezystor 100 om trzeba zmienić na 330 i wtedy można się dolutować z tym układem do cewki oryginalnego przekaźnika 

OdpowiedzCytuj
Dodane : 15/03/2019 9:22 pm
Udostępnij:



Udostępnij
  • 1
    Share

Proszę Zaloguj Się lub Zarejestruj