Forum Smart'ny Dom

Stacja - Ukazanie d...
 

Stacja - Ukazanie danych i dostępność mqtt  

  RSS
Wenar
(@wenar)
Brygadzista Zasłużony dla Forum

Witam. Od ostatniego weekendu testuje HA.

Kwestia  pogody ppierwsza

Stacje puściłem po mqtt i ukazały mi się takie dane jak w załączniku. Temp wilg i ciśnienie odczytane tematem /all/ jak poprawić wyświetlanie danych albo jaka komenda odczytać każdy wątek z osobna?

Cujnik pm co odłączony przechodzi inne testy. 

Druga kwestia. 

Jak widać w załączniku co jakiś czas przestaje wysyłać dane pomimo iż jest dostępna w sieci lokalnej i ukazuje się panel AFE.

 

www.Smarticz.pl
Wybieram AFE + Domoticz
Od 1.11.2019r testuje hassio na dockerze
https://www.youtube.com/channel/UCRVRcxQBGOmBvQSNjvd3sHw

Cytuj
Dodane : 05/11/2019 5:45 pm
lukas121
(@lukas121)
Brygadzista Zasłużony dla Forum, Donator 2019

@Wenar brak załącznika.

OdpowiedzCytuj
Dodane : 05/11/2019 6:12 pm
Wenar
(@wenar)
Brygadzista Zasłużony dla Forum

Nie załadowało. Tu:

 

www.Smarticz.pl
Wybieram AFE + Domoticz
Od 1.11.2019r testuje hassio na dockerze
https://www.youtube.com/channel/UCRVRcxQBGOmBvQSNjvd3sHw

OdpowiedzCytuj
Dodane : 05/11/2019 6:23 pm
lukas121
(@lukas121)
Brygadzista Zasłużony dla Forum, Donator 2019

Tu masz moją konfigurację do v1.x

sensor stacja pogodowa:
- platform: mqtt
name: "Jasność"
state_topic: "/stacja_pogodowa/BH1750/lux"
unit_of_measurement: "lux"
- platform: mqtt
name: Pył PM2.5
state_topic: "/stacja_pogodowa/HPMA115S0/all"
value_template: '{{ value_json["PM25"] }}'
unit_of_measurement: "μg/m3"
- platform: mqtt
name: Pył PM10
state_topic: "/stacja_pogodowa/HPMA115S0/all"
value_template: '{{ value_json["PM10"] }}'
unit_of_measurement: "μg/m3"
- platform: mqtt
name: Temperatura
state_topic: "/stacja_pogodowa/BMx80/all"
value_template: '{{ value_json["temperature"] }}'
unit_of_measurement: "°C"
- platform: mqtt
name: Wilgotność
state_topic: "/stacja_pogodowa/BMx80/all"
value_template: '{{ value_json["humidity"] }}'
unit_of_measurement: "%"
- platform: mqtt
name: Ciśnienie
state_topic: "/stacja_pogodowa/BMx80/all"
value_template: '{{ value_json["pressure"] }}'
unit_of_measurement: "hpa"
wersji beta nie testowałem.
Nie mam pojęcia czemu masz przerwy.
OdpowiedzCytuj
Dodane : 05/11/2019 6:35 pm
Wenar
(@wenar)
Brygadzista Zasłużony dla Forum

@lukas121

Dziękijak dotrę do kompa to to wrzucę.

Pytanie 1. Czy można w configurator.yaml dodawać odwołania do różnych plików sensor?

Dla przykładu.

Include sensor-sypialnia.yaml

Include sensor-stacja.yaml

Itd.

Ponieważ dodałeś "sensor stacja pogodowa:"

 

2. Pracuje na wersji stabilnej np t6v1 i mam takie przerwy. Które tylko restart z gniazdka eliminuje.

www.Smarticz.pl
Wybieram AFE + Domoticz
Od 1.11.2019r testuje hassio na dockerze
https://www.youtube.com/channel/UCRVRcxQBGOmBvQSNjvd3sHw

OdpowiedzCytuj
Dodane : 05/11/2019 6:59 pm
lukas121
(@lukas121)
Brygadzista Zasłużony dla Forum, Donator 2019

Nie dodajesz odwołań, musisz przejść na tzw paczki. W configurator.yaml dodajesz:

packages: !include_dir_named packages
Następnie tworzysz katalog ( packages ) w folderze w którym masz configurator.yaml

W nim już robisz sobie odpowiednie pliki yaml np pogoda.yaml lampy.yaml itd

OdpowiedzCytuj
Dodane : 05/11/2019 7:10 pm
Wenar
(@wenar)
Brygadzista Zasłużony dla Forum

@lukas121

Teraz mam tak

www.Smarticz.pl
Wybieram AFE + Domoticz
Od 1.11.2019r testuje hassio na dockerze
https://www.youtube.com/channel/UCRVRcxQBGOmBvQSNjvd3sHw

OdpowiedzCytuj
Dodane : 05/11/2019 8:41 pm
lukas121
(@lukas121)
Brygadzista Zasłużony dla Forum, Donator 2019

Jaka wersja T6 ?, zamieniłeś "stacja_pogodowa" na swoją nazwę ?

OdpowiedzCytuj
Dodane : 06/11/2019 8:29 am
Wenar
(@wenar)
Brygadzista Zasłużony dla Forum

@lukas121

Nazwę mam /stacja/

Także z twojego kodu wywaliłem po jednym wyrazie. 

Lux mi odczytuje a pozostałe już nie.

T6. V1. Wersja stabilna.

www.Smarticz.pl
Wybieram AFE + Domoticz
Od 1.11.2019r testuje hassio na dockerze
https://www.youtube.com/channel/UCRVRcxQBGOmBvQSNjvd3sHw

OdpowiedzCytuj
Dodane : 06/11/2019 8:34 am
lukas121
(@lukas121)
Brygadzista Zasłużony dla Forum, Donator 2019

Tak ale 1.0 czy 1.0.1 ? Zainstaluj najnowsza 1.0.1 bo 1.0 miała złą składnie json i to może być powodem że reszty ci nie odczytuje.

OdpowiedzCytuj
Dodane : 06/11/2019 8:59 am
Wenar
(@wenar)
Brygadzista Zasłużony dla Forum

niestety 1.0.0

www.Smarticz.pl
Wybieram AFE + Domoticz
Od 1.11.2019r testuje hassio na dockerze
https://www.youtube.com/channel/UCRVRcxQBGOmBvQSNjvd3sHw

OdpowiedzCytuj
Dodane : 06/11/2019 1:44 pm
lukas121
(@lukas121)
Brygadzista Zasłużony dla Forum, Donator 2019

Aktualizuj do najnowszej i będzie działać.

OdpowiedzCytuj
Dodane : 06/11/2019 7:14 pm
Wenar
(@wenar)
Brygadzista Zasłużony dla Forum

Hmmm... Sytuacja wygląda następująco.

Bez znaczenia czy wersja 1.0.0 czy 1.0.1

Logi z mqtt-HA-addons

Link: https://pastebin.com/dywYPcuz

Stacja co jakiś nie regularny czas odłącza się od neta i przechodzi w stan nieznany. Bo nie ma ani w sieci lokalnej ani w nie przechodzi w tryb ap.

Przerwy widoczne na screenie. Powrót tylko po odłączeniu zasilania i ponownym podłączeniu.

www.Smarticz.pl
Wybieram AFE + Domoticz
Od 1.11.2019r testuje hassio na dockerze
https://www.youtube.com/channel/UCRVRcxQBGOmBvQSNjvd3sHw

OdpowiedzCytuj
Dodane : 15/11/2019 5:34 pm
Udostępnij:



Udostępnij
  • 1
    Share

Proszę Zaloguj Się lub Zarejestruj