Powiadomienia
Wyczyść wszystko

Nowość AFE Firmware T2 DHTxx: Wsparcie HA, Domoticz z MQTT AutoDiscovery

13 Wpisów
2 Użytkownicy
1 Likes
606 Wyświetleń
adrian
Wpisów: 3883
Zasłużony dla Forum, Patron Strony
Autor tematu
(@adrian)
Szefu
Dołączył: 10 lat temu

Hey, jeśli ktoś używa AFE T2 z czujnikami DHT11,21,22,RT03, AM2302, RHT03

to jest dostępna wersja testowa do popykania. 

AFE Firmware T2 3.3.4

Główne zmiany to

  • dodane wsparcie ESP32
  • MQTT Auto-discovery dla HA - czyli automatyczne dodanie urządzenia do HA to samo dla nowego Domoticz (ale trzeba zainstalować wersję HA
  • wszystkie zmiany jakie doszły między wersjami 3.0 a 3.3 np, nowe MQTT, nowe WiFi itp

 

Poglądowo co jest dodane do HA automatycznie:

image

A tutaj w domoticz

image
image
image
12 Odpowiedzi
norbert740
Wpisów: 60
Donator 2K22
(@norbert740)
Senior
Dołączył: 2 lata temu

@adrian Cześć działa soft ale dziwnie się wyświetlają sensory bo ja mam DHT22 z temp i wilgotnosc a tu mam sporo encji do wyboru czemu?

T2

Czy tak ?ma być

MQTT w HA łączy się bez problemu z T2

Odpowiedz
8 Odpowiedzi
adrian
Zasłużony dla Forum, Patron Strony
(@adrian)
Dołączył: 10 lat temu

Szefu
Wpisów: 3883

@norbert740 tak ma być, to wszystko jest w stanie AFE wycisnąć z tego czujnika.

pzdr.

Odpowiedz
norbert740
Donator 2K22
(@norbert740)
Dołączył: 2 lata temu

Senior
Wpisów: 60

@adrian super to w takim razie instalacja przebiegła sprawnie i na razie działa wszystko ok bez problemu połączył się z HA

@adrian po restarcie MQTT lub HA nie staje T2 musze wyłączyć i włączyć ponownie zasilanie zeby się skomunikował z HA to co zauważyłem na chwile obecną. Inne urządzenia z AFE wstają poprawnie nawet stacja pogodowa wstaje.

Odpowiedz
adrian
Zasłużony dla Forum, Patron Strony
(@adrian)
Dołączył: 10 lat temu

Szefu
Wpisów: 3883

@norbert740 zaznacz w konfiguracji MQTT Brokera w AFE: Pamiętaj LWT - a jeśli miałeś zaznaczone to daj znać

Odpowiedz
norbert740
Donator 2K22
(@norbert740)
Dołączył: 2 lata temu

Senior
Wpisów: 60

@adrian  miałem zaznaczone we wszystkich konfiguracjach mam zaznaczone bo w przeciwnym razie po restarcie HA nie odświerzenia encji 

Odpowiedz
adrian
Zasłużony dla Forum, Patron Strony
(@adrian)
Dołączył: 10 lat temu

Szefu
Wpisów: 3883

@norbert740 pobierz najnowsza wersje - automatyczna aktualizacja w AFE: Pobierz i Aktualizuj powinna ją ściągnąć lub wygrywając plik firmware przez przeglądarkę

Dodałem taki parametr, jak pamiętanie konfiguracji urządzenia przez MQTT Broker. Domyślnie powinno być zaznaczone.

image

 

Powinno to rozwiązywać ten problem, opisany również tutaj.

Zaznaczenie tego box'a ma też swoje minusy, tzn. gdy usuniesz urządzenie z Home Assistant i nawet odłączysz to urządzenie fizyczne to przy restarcie HA będzie przychodziła konfiguracja tego urządzenia z MQTT Brokera.

Żeby nie przychodziła, trzeba ją usunąć z MQTT Brokera, na przykład

  • poprzez rekonfigurację w AFE i nie zaznaczanie tego box'a przed odłączeniem na stałe urządzenia lub 
  • usunięcie konfiguracji korzystając np. z MQTT Explorera. 

Daj znać czy u Ciebie rozwiązuje problem

Pozdrawiam, adrian

Odpowiedz
norbert740
Donator 2K22
(@norbert740)
Dołączył: 2 lata temu

Senior
Wpisów: 60

@adrian niestety nie muszę zrestartowac urządzenie lub odłaczyć go od prądu i podłaczyć ponownie.

Wygląda to tak jak by T2 nie wysyłało informacji co np 10s Stacja pogodowa i inne urządzenia widzę że wysyłają co 10s zadeklarowane informacje.

nagralem filmik ale nie wiem jak ci go wysłac 

Odpowiedz
adrian
Zasłużony dla Forum, Patron Strony
(@adrian)
Dołączył: 10 lat temu

Szefu
Wpisów: 3883

@norbert740 wrzuć tutaj jak możesz

Odpowiedz
norbert740
Donator 2K22
(@norbert740)
Dołączył: 2 lata temu

Senior
Wpisów: 60

@adrian Ok przesłałem jak zobaczysz na filmie stacja pogodowa co 10 s wysyła informacje która się odświeża a T2 nic się nie dzieje mimo ze dioda zaświeca się co 10s

Odpowiedz
adrian
Wpisów: 3883
Zasłużony dla Forum, Patron Strony
Autor tematu
(@adrian)
Szefu
Dołączył: 10 lat temu

Sprawdziłem i rzeczywiście jest taki efekt

  • Jesteś pewien że inne AFE działają T0, T1 - które używają auto-discovery, bo u mnie nie działają też? AFE T6 masz skonfigurowane ręcznie - to innych mechanizm
  • AFE jako takie działa, nic się z nim nie dzieje
  • Wygląda na to, że za każdym razem, gdy HA wstaje trzeba do niego wysłać konfigurację z AFE - trochę bez sensu, ale mogę dołożyć, pamiętanie konfiguracji w MQTT brokerze. 
  • zrobię dzisiaj T2 na próbę - dam znać

Pozdrawiam, adrian

Odpowiedz
adrian
Wpisów: 3883
Zasłużony dla Forum, Patron Strony
Autor tematu
(@adrian)
Szefu
Dołączył: 10 lat temu

zrobiłem to samo co Ty u siebie i chodzi. nagrałem tez swoja konfiguracje afe - zobacz co masz inaczej skonfigurowane.

wideo jest w tym samym folderze

pzdr.a

Odpowiedz
1 Reply
norbert740
Donator 2K22
(@norbert740)
Dołączył: 2 lata temu

Senior
Wpisów: 60

Ok sprawdzę jeszcze dziś się pobawię 

Odpowiedz
Udostępnij: