Forum Smart'ny Dom

Problem z instalacj...
 

Problem z instalacja Domoticza  

  RSS
korzeniewski36
(@korzeniewski36)
Młodzik

Witam, po raz drugi w życiu korzystam z linuksa, zainstalowem domoticza z polecenia "curl -L  https://install.domoticz.com | bash"

Wsystko przeszlo pomyślnie, pokazal sie ze wystartowal na danym adresie lecz w rzeczywistości nie wystartował. Brak połączenia z nim przez przegladarke.Recznie tez nie moge go uruchomic. Dodalem zdjecie o co konkretnie chodzi. Prosze o pomoc

Drugie zdjecie przedstawia status domoticza po restarcie systemu

  1. IMG_20190405_150850.jpg
Cytuj
Dodane : 05/04/2019 3:15 pm
Grzegorz S.
(@gslabik)
Młodzik

Spróbuj najpierw komendę

chmod +x ./domoticz

OdpowiedzCytuj
Dodane : 05/04/2019 3:44 pm
korzeniewski36
(@korzeniewski36)
Młodzik

To już robilem, nic nie pomaga, sorry ale w jestem w tym zielony....

OdpowiedzCytuj
Dodane : 05/04/2019 3:59 pm
isom
 isom
(@isom)
Zasłużony Moderator

Twoja fotka mówi ze domoticz nie jest uruchomoiny może tak 

sudo /etc/init.d/domoticz.sh restart
OdpowiedzCytuj
Dodane : 05/04/2019 7:16 pm
korzeniewski36
(@korzeniewski36)
Młodzik

pi@raspberry:~ $ sudo /etc/init.d/domoticz.sh restart
[ ok ] Restarting domoticz.sh (via systemctl): domoticz.service.
pi@raspberry:~ $ sudo service domoticz.sh status
● domoticz.service - LSB: Home Automation System
Loaded: loaded (/etc/init.d/domoticz.sh; generated; vendor preset: enabled)
Active: active (exited) since Fri 2019-04-05 19:30:01 CEST; 20s ago
Docs: man:systemd-sysv-generator(8)
Process: 1815 ExecStop=/etc/init.d/domoticz.sh stop (code=exited, status=0/SUC
Process: 1825 ExecStart=/etc/init.d/domoticz.sh start (code=exited, status=0/S

kwi 05 19:30:01 raspberry systemd[1]: Starting LSB: Home Automation System...
kwi 05 19:30:01 raspberry domoticz.sh[1825]: start-stop-daemon: unable to start
kwi 05 19:30:01 raspberry systemd[1]: Started LSB: Home Automation System.
lines 1-10/10 (END)

 

 

 

 

 

 

 

 

 

 

 

● domoticz.service - LSB: Home Automation System
Loaded: loaded (/etc/init.d/domoticz.sh; generated; vendor preset: enabled)
Active: active (exited) since Fri 2019-04-05 19:30:01 CEST; 20s ago
Docs: man:systemd-sysv-generator(8)
Process: 1815 ExecStop=/etc/init.d/domoticz.sh stop (code=exited, status=0/SUCCESS)
Process: 1825 ExecStart=/etc/init.d/domoticz.sh start (code=exited, status=0/SUCCESS)

kwi 05 19:30:01 raspberry systemd[1]: Starting LSB: Home Automation System...
kwi 05 19:30:01 raspberry domoticz.sh[1825]: start-stop-daemon: unable to start /home/pi/domoticz/domot
kwi 05 19:30:01 raspberry systemd[1]: Started LSB: Home Automation System.
~
~
~
~
~
~
~
~
~
~
~
~
~
lines 1-10/10 (END)

 

 

 

 

 

 

 

 

 

 

 

● domoticz.service - LSB: Home Automation System
Loaded: loaded (/etc/init.d/domoticz.sh; generated; vendor preset: enabled)
Active: active (exited) since Fri 2019-04-05 19:30:01 CEST; 20s ago
Docs: man:systemd-sysv-generator(8)
Process: 1815 ExecStop=/etc/init.d/domoticz.sh stop (code=exited, status=0/SUCCESS)
Process: 1825 ExecStart=/etc/init.d/domoticz.sh start (code=exited, status=0/SUCCESS)

kwi 05 19:30:01 raspberry systemd[1]: Starting LSB: Home Automation System...
kwi 05 19:30:01 raspberry domoticz.sh[1825]: start-stop-daemon: unable to start /home/pi/domoticz/domoticz (No such file or d
kwi 05 19:30:01 raspberry systemd[1]: Started LSB: Home Automation System.

OdpowiedzCytuj
Dodane : 05/04/2019 7:35 pm
korzeniewski36
(@korzeniewski36)
Młodzik

Dalej to samo

OdpowiedzCytuj
Dodane : 05/04/2019 7:35 pm
isom
 isom
(@isom)
Zasłużony Moderator

To poprosze o okno z

 sudo nano /etc/init.d/domoticz.sh

utworzyłeś katalog dla domoticza i jakie porty ustawiłeś przy instalacji 

OdpowiedzCytuj
Dodane : 05/04/2019 8:33 pm
Piotr.Kotlorz
(@piotr-kotlorz)
Młodzik

Witam czy problem został rozwiązany?

Mam dokładnie to samo próbowałem nawet na nowo zainstalować całość .

Domoticz aktualnie startuje i zatrzymuje się. jedynym sposobem na uruchomienie systemu jest ponowna instalacja i działa do wyłączenia napięcia na malinie

OdpowiedzCytuj
Dodane : 04/06/2019 11:31 pm
isom
 isom
(@isom)
Zasłużony Moderator

Musisz sobie skonfigurować auto-start domoticza   https://www.domoticz.com/wiki/Linux.

albo pobrać obraz z tego forum i tam jest już wszystko skonfigurowane 

OdpowiedzCytuj
Dodane : 05/06/2019 10:06 am
Piotr.Kotlorz
(@piotr-kotlorz)
Młodzik

Pobrałem obraz z forum przywróciłem kopie i zainstalowałem dashticz-v2.

Dalej mam ten sam problem domoticz załącza się i zamyka wyłapałem loga z domoticza może to coś pomoże bo ja już nie daje rady.

2019-06-07 18:48:36.965 Error: mainworker seems to have ended or hung unexpectedly (last update 511.000000 seconds ago)
2019-06-07 18:48:36.966 Error: Domoticz(522) is exiting due to watchdog triggered

Ps problem jest tylko wtedy gdy wyłączę napięcie na minimum 15 minut.

OdpowiedzCytuj
Dodane : 07/06/2019 6:56 pm
isom
 isom
(@isom)
Zasłużony Moderator

Moim zdaniem to coś z zainstalowanego sprzętu powoduje zadziałanie watchdoga , jak dasz radę to wyłącz wszystko co masz w Sprzęt - wtyczki , urządzenia typu Z-vawe , najlepiej wszystko i sprawdź jak wstanie normalnie to włączaj pojedynczo sprawdzaj  i wreszcie znajdziesz 

OdpowiedzCytuj
Dodane : 07/06/2019 7:37 pm
Piotr.Kotlorz
(@piotr-kotlorz)
Młodzik

Mam już tylko wirtualne czujniki i płytę główną raspberry

OdpowiedzCytuj
Dodane : 07/06/2019 8:16 pm
isom
 isom
(@isom)
Zasłużony Moderator

Czysta instalacja z obrazu też powoduje takie cuda ? Mam na testowym RBPi  wersję obrazu , doinstaluję Dashticz i sprawdzę , bo coś to dziwne jest

OdpowiedzCytuj
Dodane : 07/06/2019 8:26 pm
Piotr.Kotlorz
(@piotr-kotlorz)
Młodzik

Czysty obraz działa 

OdpowiedzCytuj
Dodane : 07/06/2019 8:39 pm
isom
 isom
(@isom)
Zasłużony Moderator

@piotr-kotlorz sprawdz czy po instalacji na czystym obrazie dashticza v2  będzie działać , jak nie to opisz jak instalujesz tego dashticza. U mnie na tym obrazie wszystko działa po wyłączeniu maliny na 20 minut włączyłem i wszystko startuje 

OdpowiedzCytuj
Dodane : 07/06/2019 11:19 pm
Piotr.Kotlorz
(@piotr-kotlorz)
Młodzik

Poddałem się postanowiłem postawić wszystko od nowa i klops 😪 . Zainstalowałem obraz i aktualizacja z linii komend przez SSH do wersji beta.

Było ok więc dodawałem wirtualne przyciski, zrobiłem połowę i w pewnym momencie wyłączyłem malinę. Już nie wstał domoticz ożywa dopiero po sudo reboot.

Dodałem załącznik z kopią parametrów zobacz czy u ciebie to będzie działać, boje się że problem jest w jakimś przełaczników

Plik pod linkiem

https://drive.google.com/file/d/1-2bk_kHHsjJpZapS901CxsA-KPuA4bl4/view?usp=drivesdk

OdpowiedzCytuj
Dodane : 12/06/2019 8:38 am
isom
 isom
(@isom)
Zasłużony Moderator

@piotr-kotlorz żeby sprawdzić bazę danych do której wstawiłeś link musiał bym mieć tą samą wersję domoticza i taki sam zestaw przełączników ( urządzeń) , nie bardzo rozumiem dlaczego aktualizujesz dobrą wersję 4.9 do testowej wersji beta w której nie wiadomo czy wszystko jest OK , wersje beta są tworzone do testowania i na podstawie takich testów jest tworzona wersja stabilna z aktualną stabilną nadal występują jakieś problemy o ostatniej  beta  nic nie wiem bo nie korzystam, zostań przy sprawdzonej 4,9 i nie powinno być problemów

OdpowiedzCytuj
Dodane : 12/06/2019 2:44 pm
Udostępnij:



Udostępnij
  • 1
    Share
  
Pracuję

Proszę Zaloguj Się lub Zarejestruj