Forum Smart'ny Dom

Sonoff Basic / AFE T2 1.3.3 / DHT22 odczytuje -5C  

Strona 1 / 2
  RSS
marlon
(@marlon)
Majster

Witajcie,

Mam drobny problem z odczytem temperatury z czujnika DHT22 ktory jest podlaczony do Sonoffa Basic. Zestaw ten dziala od okolo 6 miesiecy, ogolnie wszytko ok ale co jakis czas zdarza sie ze czujnik odczytuje wartosc -5C. Na poczatku zdarzalo sie to co jakies 1-2 tygodni gdy nagle ciagle odczytywal stala wartosc (-5C) ale ostatnio sie to nasililo i w tym tygodniu wywalilo go juz dwa razy. Gdy to sie wydarzy sonoff ciagle zyje, mozna go wykryc pingiem albo zalogowac sie przez http do ustawien. Rownie mozna sterowac urzadzeniem ktore jest podlaczone do tego sonoffa bez problem.

Po odlaczeniu Sonoffa i ponownym podlaczeniu go do sieci wszystko wraca do normy, wiec nie bardzo wiem gdzie jest problem.

W domu mam jeszcze inny DHT22 ktory jest rowniez podlaczony do innego sonoffa ale ten zestaw dziala bez problemow.

Jedyna znaczna roznica jest to ze DHT ktory stwarza problem jest na znacznie dluzszym kablu , pewnie jakies 1.5m (RJ45) and w drugim zestawie ten przewod jest moze o dlugosci 20-30cm.

No i oczywiscie lokalizaja , jeden jest w lazience w poblizy boilera gazowego a drugi w salonie w bardziej komfortowym miejscu.

Prosze piszcie jesli ktos spotkal sie z podobnym problemem.

 

Cytuj
Dodane : 09/05/2019 8:04 pm
Tagi tematu
isom
 isom
(@isom)
Dyrektor Moderator Zasłużony dla Forum, Donator 2019

Moim zdaniem pada DHT , jak masz mozliwość to zamień te czujniki miejscami i wtedy się upewnisz.

OdpowiedzCytuj
Dodane : 10/05/2019 8:37 pm
marlon
(@marlon)
Majster

Probowalem z nowiutkim czujnikiem ale problem pojawia sie co kilka dni. Byc moze to wina zaklucen, moze sprobuje poprawadzic data przewody inaczej zdala od przewodow z napieciem. Dam znac na forum.

I jeszcze jedno. Soft na tym Sonoffie to T2 1.3.3 moge sprobowac wgrac nowsza wersje 1.4.0 jesli myslisz ze moze pomoc jakby tam byl jakis znany problem.

OdpowiedzCytuj
Dodane : 14/05/2019 5:34 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

mam jedno urządzenie gdzie mam taki sam problem - ale nie miałem okazji zdiagnozować go - to -5st wyskakuje od czasu do czasu

mam te urządzenie blisko (30cm) od silnika 

Nie odpowiadam na prośby o pomoc, sugestie przez wiadomości prywatne - pisz na Forum! Dzięki za zrozumienie.

OdpowiedzCytuj
Dodane : 14/05/2019 6:17 pm
marlon
(@marlon)
Majster

Nie wiem czy u Ciebie jest podobnie, w moim wypadku gdy czujnik zaczyna wskazywac -5C to wtedy tylko zresetowanie urzadzenia przywraca poprawny odczyt. Bez odlaczania zasilania wisial by ciagle na wartosci -5C w nieskonczonosc.

Na szczescie mam regule z powiadomieniem gdy to sie stanie takze jak jestem w domu to od razu szybki reset. Jak mnie nie w poblizu to dopiero jak wracam do domu. Jest to troche denerwujace bo psuje mi to historie pomiarow na wykresie 😉 

A tak na boku zapytam czy jest mozliwosc zresetowania Sonoffa z AFE poprzez openhab za pomoca przycisku ? Ewentualnie moglbym ustawic reset automatyczny gdy zaczyna pokazywac wartosc -5C.

OdpowiedzCytuj
Dodane : 14/05/2019 6:54 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

u mnie wraca po jakimś czasie do odczytów - ale to bardziej po jakimś czasie: godzinach, może dniach - nie analizowałem tego

tak możesz zresetować sonoff, jeśli używasz MQTT to pierwsza komenda w tej rozpisce

https://www.smartnydom.pl/afe-firmware-pl/integracja/mqtt/

Nie odpowiadam na prośby o pomoc, sugestie przez wiadomości prywatne - pisz na Forum! Dzięki za zrozumienie.

OdpowiedzCytuj
Dodane : 14/05/2019 11:03 pm
marlon
(@marlon)
Majster

Dzieki @adrian . Akurat dzisiaj znowu DHT zaczal wskazywac -5C od okolo poludnia. Po powrocie z pracy dodalem switch w sitemap do restartu sonoffa. Po przelaczeniu wlacznika z pozycji off-on-off widze w mqtt.fx ze komende napewno wysyla. Rowniez sledzac ping do urzadzenia widze ze znika na kilka sekund czyli wykonuje ten restart. Natomiast czujnik ciagle pokazuje wartosc -5C. Wykonalem kilka takich restartow odczekujac dluzszy czas ale wskazanie ciagle -5C. W mqtt.fx nie widac zeby bylo jakiekolwiek uaktualnienie temperatury or wilgotnosci, mam ustawione odswiezanie co 60 sekund.

Po recznym odlaczeniu zasilania DHT odzywia i wskazuje poprawnie. Nie mialem jeszcze czasu sprobowal wymienic przewody ale chcialem spytac czy zauwazyles jakis postep u siebie, pisales ze masz podobny problem.

OdpowiedzCytuj
Dodane : 16/05/2019 10:28 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

hey, nie analizowałem jeszcze. Ten mój podłaczony jest przy sterowniku do bramy - czekam na lepszą pogodę (leje u mnie), żeby rozebrać i do niego dostać się.

Nie odpowiadam na prośby o pomoc, sugestie przez wiadomości prywatne - pisz na Forum! Dzięki za zrozumienie.

OdpowiedzCytuj
Dodane : 16/05/2019 10:50 pm
marlon
(@marlon)
Majster

Witajcie,

Adrian czy miałeś czas analizować ten temat u siebie ? U mnie ten problem zaczął mi bardziej dokuczać , w ostatnich dniach czujnik zaczął mi się wieszac prawie codziennie. Jak pisałem wcześniej sam restart zdalny nie pomaga a jedynie odłączenie zasilania. 

Probowalem już z nowym sonoffem i nowym czujnikiem , bez zmian. Daj znać czy masz jakieś wiadomości. 

Pozdrawiam 

OdpowiedzCytuj
Dodane : 12/06/2019 12:19 am
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

cześć, nie miałęm możliwości - ciągła podróż służbowa

zainstaluj wersję 1.4.0 - jak będzie to samo to spróbuj 1.2.3, która ma zupełnie inną bibliotekę do obsługi tego czujnika

https://github.com/tschaban/AFE-Firmware/tree/master/bin/AFE%20Firmware%20T2%20(DHxx)/ESP8266

Nie odpowiadam na prośby o pomoc, sugestie przez wiadomości prywatne - pisz na Forum! Dzięki za zrozumienie.

OdpowiedzCytuj
Dodane : 12/06/2019 7:53 am
isom
 isom
(@isom)
Dyrektor Moderator Zasłużony dla Forum, Donator 2019

@marlon a testowałeś to na sonoff bez obciążenia ? Tzn sonoff + dht i wyjście sonoff swobodne 

OdpowiedzCytuj
Dodane : 12/06/2019 7:16 pm
marlon
(@marlon)
Majster

Część,

Zmieniłem soft z 1.3.3 na 1.2.3 dzisiaj wieczorem wiec zobaczymy jakie będą efekty za dzień lub kilka. Jeśli nie będzie zmian to spróbuje 1.4.0 w następnej kolejności. 

@isom Nie miałem okazji odłączyć obciążenie od Sonoffa bo tutaj jeszcze sezon grzewczy trwa , farelka jest w ciągłym użytku 😉. Jeśli zmiana softu nie pomoże to napewno spróbujemy odłączyć obciążenie. 

Poinformuje o sytuacji w weekend. 

Pozdrawiam

OdpowiedzCytuj
Dodane : 14/06/2019 12:15 am
marlon
(@marlon)
Majster

Witam,

Obiecalem poinformowac o sytuacji po zmianie softu.

Jak pisalem wyzej AFE T2 zmienilem z 1.3.3 na 1.2.3 w ostatni Piatek (14/06). Na drugi dzien zdarzyla sie sytuacja ze czujnik sie zawiesil bo ciagle pokazywal ta sama temperature przez kilka godzin. Po odlaczeniu zasilania problem znikl i wszystko dzialalo bez zarzutow do dzisiaj (19/06 Sroda). Wiec jakies 5 dni nie bylo zadnego problemu. Dzisiaj okolo poludnia czujnik sie znowu zawiesil i przez nastepne 5 godzin wskazywal 20 stopni. Po restarcie znowu pracuje ok.

Wiec po zmianie softu nie mam juz wiecej problemu z czujnikiem pokazujacym -5C co jakis czas jak na 1.3.3 za to natomiast jest ten drugi problem z zawieszaniem sie.

Poczekam jeszcze kilka dni i zapewne sprobuje T2 1.4.0.

Nie wiem czy ktos jeszcze boryka sie z podobnymi problemami czy tylko ja 😉 

Pozdrawiam

DHT22-Dzisiaj.PNG

OdpowiedzCytuj
Dodane : 19/06/2019 9:49 pm
Krzysztofch
(@krzysztofch)
Brygadzista Zasłużony dla Forum, Donator 2019

Ja uzywam versje 1.3.0 od powstania jej .  Niechcialo mi sie w tamtym czasie znow zmieniac tej wersji  w lazience i tak zostal do dzis. . Czujnik z sonofem podlaczony na 5v. Jest jedna wada tej wersji. Jak czujnik zgubi odczyt to bierze poprzedni odczyt. Mi to akurat w lazience nie przeszkadzalo bo dziala tak jak chcialem. Nawet jak zgubilo odczyt to po min znow czujnik wysyla bierzacy odczyt.w koncu ktorys trafi,W praktyce nie jest to zle w moim przypadku  

W lazience mi to nie przeszkadza bo tam wlancza sie grzejnik elektryczny po kapieli do suszenia recznikow. Gdy jest pow 90%, i tez jest uzaleznione od temp zew i czasow.  I to akurat w blockly. 

Adrian chyba tej wersji  za duzo nie rozpowszechnial bo jest ta wada ktora wspomnialem. Wersji 1.4.0 nie testowalem. I mysle ze ona bedzie najlepsza. 

OdpowiedzCytuj
Dodane : 20/06/2019 2:49 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

może mógłby się jakiś elektronik wypowiedzieć?

tutaj wykres DH22 podłączony do gołego ESP8266, bez żadnych dodatkowych przekaźników / urządzeń podłączonych. Konkretnie to tutaj.

Wykres z ostatnich 6 miesięcy. Nie mam zwieszek wszystko gitara.

Fakt jest że mam jeden ESP8266 do któego podłączony jest DH22 steruje on bramą. Siedzi on w tej puszcze. I tutaj dostaję -5V, nie mam chwili, żeby to rozmontować i próbować się bawić - jest tam mnóstwo różnych elementów i założyłem, że coś może zakłócać.

jakiś pomysł?

Nie odpowiadam na prośby o pomoc, sugestie przez wiadomości prywatne - pisz na Forum! Dzięki za zrozumienie.

OdpowiedzCytuj
Dodane : 20/06/2019 3:47 pm
isom
 isom
(@isom)
Dyrektor Moderator Zasłużony dla Forum, Donator 2019

Generalnie czujniki DHT są bardzo wrażliwe na skoki napięcia , jest to spowodowane między innymi tym że wykonanie pomiaru przez czujnik trwa aż 2 sek , to bardzo długo w porównaniu np z DS 18B20 . Pisałem już żeby kolega @marlon sprawdził sobie działanie tego czujnika bez obciązenia "farelką " , ale spostrzeżenia @adrian tylko to potwierdzają. Czujnik podłączony do gołego ESP i 6 miesięcy spokój i drugi który jest zasilony z tego samego zasilania co silnik bramy ( prąd rozruchowy ) i zdarzają się zwiechy.  

OdpowiedzCytuj
Dodane : 20/06/2019 10:03 pm
adrian polubień
marlon
(@marlon)
Majster

@isom

Bardzo chciałbym sprawdzić zachowanie Sonoffa po odłączeniu farelki ale sezon grzewczy jeszcze się nie skończył 😉.

Jak tylko będzie to możliwe to odłącze i podam informacje. 

Teraz na T2 1.2.3 jest zdecydowanie lepiej jak pisałem wyżej , chociaż jak się Sonoff zawiesi to wtedy tylko odłączenie zasilania naprawia problem. Do każdego z Sonoffow mam „reboot” opcje z openHAB ale to wtedy nic nie daje same resetowanie. 

A jeszcze spytam czy gdyby Sonoff gubił sygnał Wifi czy to mogło by spowodować podobne problemy. Ten zestaw w łazience jest daleko od routera i czasami zdarza się ze traci łączność z routerem kilkukrotnie w ciągu dnia. 

OdpowiedzCytuj
Dodane : 21/06/2019 2:35 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

raczej gubienie sygnału WiFi nie powinno mieć wpływ z pkt. widzenia oprogramowania.

Nie odpowiadam na prośby o pomoc, sugestie przez wiadomości prywatne - pisz na Forum! Dzięki za zrozumienie.

OdpowiedzCytuj
Dodane : 21/06/2019 9:07 pm
Espablo
(@espablo)
Młodzik

Zrobiłem mały test tych czujników. Zapraszam do oglądania

https://youtu.be/FBSoQzKS2Vo

i czytania

https://forum.supla.org/viewtopic.php?p=47110#p47110

OdpowiedzCytuj
Dodane : 19/08/2019 10:35 pm
isom i adrian polubień
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

mogę tylko dodać, że mój, który zwraca ni z gruchy ni z pietruchy -5st jest ANSRI 😉

dzięki @espablo

Nie odpowiadam na prośby o pomoc, sugestie przez wiadomości prywatne - pisz na Forum! Dzięki za zrozumienie.

OdpowiedzCytuj
Dodane : 19/08/2019 10:47 pm
Strona 1 / 2
Udostępnij:



Udostępnij
  • 1
    Share

Proszę Zaloguj Się lub Zarejestruj