Forum Smart'ny Dom

Sonoff Basic / AFE T2 1.3.3 / DHT22 odczytuje -5C  

  RSS
marlon
(@marlon)
Majster

Witajcie,

Mam drobny problem z odczytem temperatury z czujnika DHT22 ktory jest podlaczony do Sonoffa Basic. Zestaw ten dziala od okolo 6 miesiecy, ogolnie wszytko ok ale co jakis czas zdarza sie ze czujnik odczytuje wartosc -5C. Na poczatku zdarzalo sie to co jakies 1-2 tygodni gdy nagle ciagle odczytywal stala wartosc (-5C) ale ostatnio sie to nasililo i w tym tygodniu wywalilo go juz dwa razy. Gdy to sie wydarzy sonoff ciagle zyje, mozna go wykryc pingiem albo zalogowac sie przez http do ustawien. Rownie mozna sterowac urzadzeniem ktore jest podlaczone do tego sonoffa bez problem.

Po odlaczeniu Sonoffa i ponownym podlaczeniu go do sieci wszystko wraca do normy, wiec nie bardzo wiem gdzie jest problem.

W domu mam jeszcze inny DHT22 ktory jest rowniez podlaczony do innego sonoffa ale ten zestaw dziala bez problemow.

Jedyna znaczna roznica jest to ze DHT ktory stwarza problem jest na znacznie dluzszym kablu , pewnie jakies 1.5m (RJ45) and w drugim zestawie ten przewod jest moze o dlugosci 20-30cm.

No i oczywiscie lokalizaja , jeden jest w lazience w poblizy boilera gazowego a drugi w salonie w bardziej komfortowym miejscu.

Prosze piszcie jesli ktos spotkal sie z podobnym problemem.

 

Cytuj
Dodane : 09/05/2019 8:04 pm
Tagi tematu
isom
 isom
(@isom)
Zasłużony Moderator

Moim zdaniem pada DHT , jak masz mozliwość to zamień te czujniki miejscami i wtedy się upewnisz.

OdpowiedzCytuj
Dodane : 10/05/2019 8:37 pm
marlon
(@marlon)
Majster

Probowalem z nowiutkim czujnikiem ale problem pojawia sie co kilka dni. Byc moze to wina zaklucen, moze sprobuje poprawadzic data przewody inaczej zdala od przewodow z napieciem. Dam znac na forum.

I jeszcze jedno. Soft na tym Sonoffie to T2 1.3.3 moge sprobowac wgrac nowsza wersje 1.4.0 jesli myslisz ze moze pomoc jakby tam byl jakis znany problem.

OdpowiedzCytuj
Dodane : 14/05/2019 5:34 pm
adrian
(@adrian)
Prezes

mam jedno urządzenie gdzie mam taki sam problem - ale nie miałem okazji zdiagnozować go - to -5st wyskakuje od czasu do czasu

mam te urządzenie blisko (30cm) od silnika 

OdpowiedzCytuj
Dodane : 14/05/2019 6:17 pm
marlon
(@marlon)
Majster

Nie wiem czy u Ciebie jest podobnie, w moim wypadku gdy czujnik zaczyna wskazywac -5C to wtedy tylko zresetowanie urzadzenia przywraca poprawny odczyt. Bez odlaczania zasilania wisial by ciagle na wartosci -5C w nieskonczonosc.

Na szczescie mam regule z powiadomieniem gdy to sie stanie takze jak jestem w domu to od razu szybki reset. Jak mnie nie w poblizu to dopiero jak wracam do domu. Jest to troche denerwujace bo psuje mi to historie pomiarow na wykresie 😉 

A tak na boku zapytam czy jest mozliwosc zresetowania Sonoffa z AFE poprzez openhab za pomoca przycisku ? Ewentualnie moglbym ustawic reset automatyczny gdy zaczyna pokazywac wartosc -5C.

OdpowiedzCytuj
Dodane : 14/05/2019 6:54 pm
adrian
(@adrian)
Prezes

u mnie wraca po jakimś czasie do odczytów - ale to bardziej po jakimś czasie: godzinach, może dniach - nie analizowałem tego

tak możesz zresetować sonoff, jeśli używasz MQTT to pierwsza komenda w tej rozpisce

https://www.smartnydom.pl/afe-firmware-pl/integracja/mqtt/

OdpowiedzCytuj
Dodane : 14/05/2019 11:03 pm
marlon
(@marlon)
Majster

Dzieki @adrian . Akurat dzisiaj znowu DHT zaczal wskazywac -5C od okolo poludnia. Po powrocie z pracy dodalem switch w sitemap do restartu sonoffa. Po przelaczeniu wlacznika z pozycji off-on-off widze w mqtt.fx ze komende napewno wysyla. Rowniez sledzac ping do urzadzenia widze ze znika na kilka sekund czyli wykonuje ten restart. Natomiast czujnik ciagle pokazuje wartosc -5C. Wykonalem kilka takich restartow odczekujac dluzszy czas ale wskazanie ciagle -5C. W mqtt.fx nie widac zeby bylo jakiekolwiek uaktualnienie temperatury or wilgotnosci, mam ustawione odswiezanie co 60 sekund.

Po recznym odlaczeniu zasilania DHT odzywia i wskazuje poprawnie. Nie mialem jeszcze czasu sprobowal wymienic przewody ale chcialem spytac czy zauwazyles jakis postep u siebie, pisales ze masz podobny problem.

OdpowiedzCytuj
Dodane : 16/05/2019 10:28 pm
adrian
(@adrian)
Prezes

hey, nie analizowałem jeszcze. Ten mój podłaczony jest przy sterowniku do bramy - czekam na lepszą pogodę (leje u mnie), żeby rozebrać i do niego dostać się.

OdpowiedzCytuj
Dodane : 16/05/2019 10:50 pm
marlon
(@marlon)
Majster

Witajcie,

Adrian czy miałeś czas analizować ten temat u siebie ? U mnie ten problem zaczął mi bardziej dokuczać , w ostatnich dniach czujnik zaczął mi się wieszac prawie codziennie. Jak pisałem wcześniej sam restart zdalny nie pomaga a jedynie odłączenie zasilania. 

Probowalem już z nowym sonoffem i nowym czujnikiem , bez zmian. Daj znać czy masz jakieś wiadomości. 

Pozdrawiam 

OdpowiedzCytuj
Dodane : 12/06/2019 12:19 am
adrian
(@adrian)
Prezes

cześć, nie miałęm możliwości - ciągła podróż służbowa

zainstaluj wersję 1.4.0 - jak będzie to samo to spróbuj 1.2.3, która ma zupełnie inną bibliotekę do obsługi tego czujnika

https://github.com/tschaban/AFE-Firmware/tree/master/bin/AFE%20Firmware%20T2%20(DHxx)/ESP8266

OdpowiedzCytuj
Dodane : 12/06/2019 7:53 am
isom
 isom
(@isom)
Zasłużony Moderator

@marlon a testowałeś to na sonoff bez obciążenia ? Tzn sonoff + dht i wyjście sonoff swobodne 

OdpowiedzCytuj
Dodane : 12/06/2019 7:16 pm
marlon
(@marlon)
Majster

Część,

Zmieniłem soft z 1.3.3 na 1.2.3 dzisiaj wieczorem wiec zobaczymy jakie będą efekty za dzień lub kilka. Jeśli nie będzie zmian to spróbuje 1.4.0 w następnej kolejności. 

@isom Nie miałem okazji odłączyć obciążenie od Sonoffa bo tutaj jeszcze sezon grzewczy trwa , farelka jest w ciągłym użytku 😉. Jeśli zmiana softu nie pomoże to napewno spróbujemy odłączyć obciążenie. 

Poinformuje o sytuacji w weekend. 

Pozdrawiam

OdpowiedzCytuj
Dodane : 14/06/2019 12:15 am
Udostępnij:



Udostępnij
  • 1
    Share
  
Pracuję

Proszę Zaloguj Się lub Zarejestruj