Powiadomienia
Wyczyść wszystko

ESP8266/ESP8285 [Rozwiązany] Sonoff basic r2 ESP8285 i kilka czujników temp. DS18b20

7 Wpisów
2 Użytkownicy
3 Reactions
764 Wyświetleń
Wpisów: 5
Autor tematu
(@ireneuszbaka)
Bywalec
Dołączył: 10 miesięcy temu

Chcę na Sonoff basic r2 ESP8285 podłączyć kilka czujników temp. DS18b20, wybrałem więc wersję T1. Flashowanie przebiega bez problemu, jednak potem mój sonoff nie wstaje. Wersja T0 dla sonofa wstaje poprawnie. Pytanie, czy na wersji T0 uzyskam obsługę kilku termometrów (8, może 10, min. 6)?

Docelowo chcę to podłączyć pod HA.

Typ AFE Firmware
Wersja
3.5.0
Sprzęt
Sonoff
6 Odpowiedzi
adrian
Wpisów: 3999
Admin Zasłużony dla Forum, Patron Strony
(@adrian)
Szefu
Dołączył: 10 lat temu

T1 - powinien działać bez większego problemu na Sonoff

  • czy instalowałeś z T0 (z której wersji T0) na T1 przez przeglądarkę?
  • czy instalowałeś przez  adapter USB? jeśli tak to wyczyściłeś mu flash?
  • czy instalowałeś wersję 8285
  • czy odłączyłeś go od zasilania po zainstalowaniu T1?

pzdr.a

1 Reply
(@ireneuszbaka)
Dołączył: 10 miesięcy temu

Bywalec
Wpisów: 5

@adrian

pierwsza instalacja z fabrycznego sonofa przez TTL na T1 z czyszczeniem flash. Tak, wersja 8285.

druga instalacja (z chyba T1???, albo dalej fabrycznego) przez TTL z czyszczeniem

Oczywiście, po każdym flash'u odpięcie zasilania.

Właśnie zadział mi webflash z najnowszego T0 na T1 - wcześniej na to nie wpadłem 😀

Dzięki

Wpisów: 5
Autor tematu
(@ireneuszbaka)
Bywalec
Dołączył: 10 miesięcy temu

Ale wstaje tylko przy zasilaniu 3,3V, przy 220V cisza. Czy tak ma być? Oryginalny jest zasilany z 220V.

adrian
Wpisów: 3999
Admin Zasłużony dla Forum, Patron Strony
(@adrian)
Szefu
Dołączył: 10 lat temu

no generalnie z perspektywy samego AFE zasilanie nie mam znaczenia, to coś sprzętowego raczej. Oprócz tego, że odłączasz TTL i przełączasz na 230v coś jeszcze robisz - podłączasz czujnik? jak? 

GPIO0 / przycisk w sonoff nie jest zwarty do masy podczas uruchamiania?

Wpisów: 5
Autor tematu
(@ireneuszbaka)
Bywalec
Dołączył: 10 miesięcy temu

Na razie bez czujników. Zwarcia też raczej nie ma. Zaraz sprawdzę na drugim.

Strona 1 / 2
Udostępnij: