Notifications
Clear all

one wire z RPI  

Strona 2 / 2
  RSS
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2019, Donator 2K20

@upiter81 serwis motion do obsługi kamer moim zdaniem nie powinien pracować na tym samym sprzęcie co serwer automatyki . To tak mocno obciąża procesor maliny, że wcale się nie dziwię że magistrala 1-wire się sypie . jak chcesz się przekonać to wrzuć sobie wtyczkę PiMonitor i zobacz jak wzrasta użycie pamięci i obciążenie procesora jak kamera wykrywa ruch .

Fotowoltaika nie powinna mieć wpływu , chyba że zasilanie maliny masz na podłym chińskim zasilaczu impulsowym.

OdpowiedzCytuj
Dodane : 23/06/2020 9:42 pm
Piotr
(@upiter81)
Początkujący

@isom prawdę mówiąc udało mi się już fajnie zredukować obciążenie procesora przez motion (do ok 5%) poprzez użycie drugiego kanału kamery i dopasowanie parametrów kamery z konfiguracją motion (ale kamera pozostawia wiele do życzenia - trochę się nakombinowalem aby ja spiąć z systemem, więc...). Ale faktycznie obciążenie jest mimo wszystko widoczne, więc sprawdzę jaki będzie efekt po wylaczeniu motion.

Dziękuję za wskazówkę, jutro pewnie dam znać jaki wynik.

OdpowiedzCytuj
Dodane : 23/06/2020 10:36 pm
Piotr
(@upiter81)
Początkujący

Wracam dość szybko ...

Dokładnie od północy domoticz zaczął zgłaszać standardowe błędy:

2020-06-24 01:19:56.354 Error: 1-Wire system : error reading value from /sys/bus/w1/devices/28-031897791c52
2020-06-24 01:19:56.354 Error: 1-Wire system : error reading value from /sys/bus/w1/devices/28-031897792f03
2020-06-24 01:19:56.354 Error: 1-Wire system : error reading value from /sys/bus/w1/devices/28-03189779344a

po zrobieniu back-up (codziennym skryptem, tj po zatrzymaniu i ponownym uruchomieniu domoticza), o godzinie 1:22 zgłosił ostatni błąd:

2020-06-24 01:22:42.111 Error: 1Wire: Device not yet supported in Kernel mode (Please report!) ID:not found., family: 00

po czym czujniki przestały w ogóle odpowiadać (domoticz przestał zgłaszać błędy), rano również nie widać ich było w aplikacji RaspController, dopiero po resecie magistrali (tj. zdjęciu zasilania 3.3V na 3s) + po kilku minutach, czujniki zaczęły być widoczne, ale tylko w RaspController (w domoticz nadal cisza - żadnych błędów ani odczytów…), dopiero po restarcie systemu wszystko wróciło do normy …

Nie zmieniam nic i kontynuuję obserwacje.

OdpowiedzCytuj
Dodane : 24/06/2020 7:12 am
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2019, Donator 2K20

Albo za mało wiem , albo mam szczęście. Nie zdarzyło mi się żeby przy robieniu backupu coś przestało działać .

Zaraz zrobię wymuszoną kopię całego folderu domoticz i wrzucę wykresy z grafany z użyciem procka i danymi z czujników 1-wire

Poniżej wykresy , na górnym widać dwie kopie ostatnia robiona przed chwilą , wcześniej planowana przez system . Drugi wykres to dwa czujniki podłączone na przewodzie alarmowym ( pisałem o tym wcześniej)

Czujniki leżą obok siebie dlatego w większości dane się nakładają
OdpowiedzCytuj
Dodane : 24/06/2020 1:41 pm
Piotr
(@upiter81)
Początkujący

U mnie nadal lipa..., obecnie (mam nadzieję że tymczasowo) rozwiązanie polega na odłączaniu zasilania z magistrali co 10 min. na 3s ...

Ale nie poddaję się, i planuję jeszcze kolejne testy:

1. Kondensatory 100nF między 3.3V a GND jak najbliżej czujników,

2. Podłączenie maliny do innej fazy - może akurat na tej mam więcej sprzętu emitującego zakłócenia 🤔

3. Podłączenie do innego uziemienia, np z zewnątrz,

4. Podłączenie do zewnętrznego zasilania 3.3V,

Co o tym sądzisz - ma to sens?

OdpowiedzCytuj
Dodane : 25/06/2020 7:00 pm
Piotr
(@upiter81)
Początkujący

Wracam z tematem po rozwiązaniu problemu 😀 - wystarczyło wymienić czujniki (kupiłem nowy komplet od innego sprzedawcy) ..., zmylił mnie prawdopodobnie fakt, że jednocześnie miałem najprawdopodobniej wadliwe 2 lub nawet wszystkie 3 czujniki, dlatego próby różnych konfiguracji tak bardzo wprowadzały mnie w błąd (ale co ciekawe - w konfiguracji pojedynczej każdy z nich działał poprawnie ...). Obecnie w moim prostym obwodzie wszystko działa poprawnie bez względu na ilość / miejsce połączeń oraz rodzaje przewodów (z ciekawości przetestowałem kilka różnych konfiguracji).

OdpowiedzCytuj
Dodane : 11/07/2020 10:00 am
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2019, Donator 2K20

@upiter81 dzięki za info . 

OdpowiedzCytuj
Dodane : 11/07/2020 1:20 pm
Strona 2 / 2
Udostępnij: