Forum Smart'ny Dom

[Rozwiązany] Coś nie tak z AFE firmware T2 1.3.0  

Strona 1 / 2
  RSS
janusz15813
(@janusz15813)
Młodzik

Witam

coś nie tak z AFE firmware T2 1.3.0

ping do urządzenia dochodzi, ale nie każdy,długi time, trudny kontakt  z urządzeniem żeby go konfigurować poprzez www .

Testowałem dwa Sonoff z T2 1.0.0 oraz T1 1.3.1 i było wszystko OK.

Dodane : 25/11/2018 12:28 am
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

Musisz trochę więcej informacji dostarczyć. 

  • jakie urządzenie
  • screeny z konfiguracji 

Ja mam zainstalowany 1.3.0 na jednym urządzeniu i działa poprawnie. 

OH2+AFE

Dodane : 25/11/2018 1:24 am
janusz15813
(@janusz15813)
Młodzik

Testowany Sonoff  Wersja płytki TH_v1.1 oraz Sonoff basic R2 v1.0

po wgraniu oprogramowania 1.3.0  T2 ping do urządzenia wygląda jak poniżej

C:\Users\Janusz>ping -t 192.168.0.111

Pinging 192.168.0.111 with 32 bytes of data:
Request timed out.
Request timed out.
Reply from 192.168.0.111: bytes=32 time=119ms TTL=127
Request timed out.
Reply from 192.168.0.111: bytes=32 time=60ms TTL=127
Request timed out.
Request timed out.
Request timed out.
Reply from 192.168.0.111: bytes=32 time=92ms TTL=127
Request timed out.
Request timed out.
Control-C

Co skutkuje że konfiguracja za pomocą www jest  w zasadzie nie możliwa

baaardzo wolno chodzi

Dodane : 26/11/2018 10:07 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

hey,

  • wyszczyść tego sonoff'a do "zera" flashująć Sonoff'a tym  plikiem
  • wgraj ponienie T2 wersję 8285 jeśli to Sonoff TH1.1 lub R2

daj znać czy pomogło

pozdrawiam

OH2+AFE

Dodane : 27/11/2018 12:47 am
janusz15813
(@janusz15813)
Młodzik

OK

dzięki za wsparcie

Wyczyściłem  i wgrałem  T2 1.2.2 wersję 8266  do Sonoff TH1.1 i pomogło

nastepnie wgrałem T2 1.3.0 dla 8285 i było tak samo źle.

Wieczorem zrobie jeszcze z czyszczeniem i dam znać

Nie bardzo wiem dlaczego mam wgrać wersję dla 8285 skoro na płytce są scalaki ESP8266EX ??

Dodane : 27/11/2018 11:04 am
janusz15813
(@janusz15813)
Młodzik

Z wyczyszczeniem  T2 1.3.0 dla 8285 i 8266 działa niepoprawnie.

Urządzenie po wifi się łączy, dostaje adres IP,ale ping do niego nie idzie.

Destination host unreachable.

Nie można konfigurować po WWW.dioda LED mruga 3x  co 10sekund

 

Dodane : 27/11/2018 9:09 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

Wyślij screen z konfiguracji WiFi 

uzywasz API domoticz ? Mqtt ? 

Troche trudno zgadnąć jak masz pokonfigurowane 

sprawdzilem jest ponad 60 instalacji  już wersji T2 1.30 na razie - takich jak Ty masz problemów nie było 

mruganie w jakiś takich interwałach oznacza ze albo się rozłącza albo jakoś zawiesza i ponownie łączy do WiFi 

Może nie masz czujnika temperatury - podłączonego, skonfigurowanego - może to być tez problem 

 

OH2+AFE

Dodane : 27/11/2018 10:04 pm
janusz15813
(@janusz15813)
Młodzik

Konfiguracja WiFi zawsze ta sama ,zaznaczam adres  z DHCP, router Wi i hasło

oraz czujnik DHT resztę default, nie używam API domoticz ?  ani Mqtt ?( jeszcze do tego nie doszedłem)

A jak wytłumaczyć że z tymi samymi ustawieniami na T2 1.2.2 jest OK.??

Dodane : 28/11/2018 1:16 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony
  1. Wersja 1.2.x od wersji 1.3.x różni się w środku (w kodzie) bardzo znacząco
  2. jesli masz dokladnie taka sama konfigurację to z założenia powinno działać
  3. jaką masz konfigurację nie wiem, nie widzę
  4. jeśli jest jakiś defekt związany oprogramowaniem 1.3.0 to ma trudność z diagnozowaniem bo nie jestem w stanie całej Twojej konfiguracji z replikować po swojej stronie i potestować - bo jej nie widzę
  5. Jeśłi działa Ci to co potrzebujesz w 1.2.2 używaj 1.2.2 lub innego soft

staram się pomóc, ale mam ograniczone możliwości, no i też nie ukrywam na baze wielu problemów, które dostawałem ograniczone zaufanie pomiędzy tym co słyszę a widzę  

pozdrawiam

OH2+AFE

Dodane : 28/11/2018 2:46 pm
janusz15813
(@janusz15813)
Młodzik

OK będę jeszcze testował . może do czegoś dojdę.

Ale nie odpowiedziałeś na pytanie

..dlaczego mam wgrać wersję dla 8285 skoro na płytce są scalaki ESP8266EX ??

,
Dodane : 28/11/2018 6:28 pm
isom
 isom
(@isom)
Dyrektor Moderator Zasłużony dla Forum, Donator 2019

@janusz15813 nie masz co testować wgrałem do sonoff TH 1,1 wersję 1,3,0 tego softu i zachowuje się identycznie jak opisujesz , w trybie AP wszystko jest Ok , ale po zakończeniu konfiguracji moduł nie może połączyć się z siecią . Próba przypisania na stałe IP też nic nie dała . Z poziomu AP zmieniłem wersję na 1,2,3 i ten sam moduł natychmiast połączył się z siecią i działał normalnie.

Wgrałem wersję 1,3,0 do sonoff ze starych zapasów czyli nie 1,1 i soft działa na nim świetnie.

Ogólnie wersja sonoff TH 1,1 jest jakaś kapryśna i niektóre softy dla wersji ESP 8285 znacznie lepiej na nich się zachowują dlatego @adrian zalecał taką własnie wersję.

@adrian nie wiem na ile kod wersji 1,3,0 różni się od starszych wersji , ale w przypadku tych nieszczęsnych sonoff TH 1,1 ten soft w żadnej wersji czy to 8266 czy 8285 nie działa prawidłowo.

 

Dodane : 28/11/2018 7:42 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

Ok, jak rozumem problem występuje z TH 1.1 tylko wersja 13

qrcze nie wiem czy  mam TH. Jak wrócę do PL to poszperam

OH2+AFE

Dodane : 28/11/2018 10:06 pm
isom
 isom
(@isom)
Dyrektor Moderator Zasłużony dla Forum, Donator 2019

@adrian jak nie masz tego TH1,1 to pisz na PW adres , wyślę do Ciebie co prawda używkę , ale sprawną , a problem dotyczy raczej tylko tego TH 1,1 .

Dodane : 28/11/2018 10:27 pm
adrian polubień
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

Ja wrócę i przeszukam pudło z sonoffami i jak nie znajdę to odezwę się - zrobimy jakaś podmianke 

OH2+AFE

Dodane : 28/11/2018 10:31 pm
janusz15813
(@janusz15813)
Młodzik

isom dzięki za wsparcie

bo sporo czasu spędziłem na czyszczeniu , wgrywaniu , testowaniu

i wszystko przez USB żeby testy były  w tych samych warunkach początkowych

 

Dodane : 29/11/2018 7:36 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

przepraszam @janusz15813 że spędziłeś sporo czasu na moich poradach

OH2+AFE

Dodane : 29/11/2018 9:22 pm
janusz15813
(@janusz15813)
Młodzik

Nie ma sprawy uczę się , dopiero zacząłem z Sonoff  i domoticzem

Każde doświadczenie się przydaje.

Dodane : 29/11/2018 10:41 pm
lukas121
(@lukas121)
Brygadzista Zasłużony dla Forum, Donator 2019

Sonoff basic też problemy. Po wgraniu nie ma możliwości sterowania, i ustawienia wysyłania temperatury cały czas pokazuje 0. Na wersji 1.2.2 wszystko działa bez problemu.

Dodane : 05/12/2018 9:17 am
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

Możesz napisać coś więcej:

  • z jakiej wersji aktualizowałeś, do jakiej T2.1.3.??, albo jak to robiłeś
  • jaki Sonoff Basic 

Tak, żebym mógł jakoś zreplikować problem

OH2+AFE

Dodane : 05/12/2018 8:38 pm
lukas121
(@lukas121)
Brygadzista Zasłużony dla Forum, Donator 2019

Sonoff basic R2 v1 wgrywany soft na nowego wyciągniętego z pudełka. Wgrywany T2 1.3.3

Dodane : 05/12/2018 9:35 pm
Strona 1 / 2
Udostępnij:



Udostępnij
  • 1
    Share

Proszę Zaloguj Się lub Zarejestruj