Po aktualizacji Dom...
 
Powiadomienia
Wyczyść wszystko

Po aktualizacji Domoticza do ostatniej wersji (2022.2) nie mam dostępu do Domoticza

11 Wpisów
5 Użytkownicy
0 Reactions
1,043 Wyświetleń
 skom
(@skom)
Wpisów: 38
Kontrybutor
Autor tematu
 

Po aktualizacji Domoticza do ostatniej wersji (2022.2) nie mam dostępu do Domoticza ( https://************.dataplicity.io port 80) przez Dataplicity (403 Forbidden). 🙁
Formularz dziennika Domoticz:
Błąd: Serwer WWW: Użyto wielu serwerów proxy (lub możliwa próba podszywania się), ignorując żądanie klienta (adres zdalny: 127.0.0.1)

Wersja domoticza: 2022.2
Platforma: Raspberry Pi 4

PS. Poprzednie wersje Domoticza współpracowały z Dataplicity bez żadnych problemów
PS2. W tej jak i we wcześniejszych wersjach domoticza mam/miałem ustawione
Sieci lokalne (bez hasła/loginu):
Sieci: 10.1.1.*;127.0.0.1;(+ZeroTier)
(Połączenie przez ZeroTier działa. Niestety IP generowane przez Dataplicity nie jest stałe)

 
Dodane : 13/11/2022 3:11 pm
isom
 isom
(@isom)
Wpisów: 5100
Szef wszystkich szefów Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20
 

@skom nie używam Dataplicity bo używam Zero-Tier , nie rozumiem potrzeby korzystania z tej usługi.

 
Dodane : 13/11/2022 5:19 pm
 skom
(@skom)
Wpisów: 38
Kontrybutor
Autor tematu
 

@isom Też z chęcią przeszedłbym tylko na ZeroTier, ale jak podłączę się na komórce do serwera ZeroTier (server online) aplikacje bankowe przestają się logować 🙁

 
Dodane : 13/11/2022 7:17 pm
isom
 isom
(@isom)
Wpisów: 5100
Szef wszystkich szefów Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20
 

@skom spróbuj z tą usługą https://tailscale.com/ podobno też jest super , Datapliciti to pomyłka 

 
Dodane : 13/11/2022 7:31 pm
Mariusz
(@mariusz-2)
Wpisów: 228
Weteran Donator 2K23
 

@skom Można tez tak https://www.cloudflare.com/what-is-cloudflare/ ale potrzebujesz własnej domeny.

 
Dodane : 13/11/2022 9:58 pm
 skom
(@skom)
Wpisów: 38
Kontrybutor
Autor tematu
 

Dziękuję za odpowiedzi 🙂
Jednak dostęp przez Dataplicity jest dla mnie bardzo wygodny (rózne akcje na DzVents i NodeRed są realizowane przez dataplicity, a włączanie za każdym razem ZeroTier czy TailScale to już kłopot - nie może byc cały czas online przez te usługi - drenaż baterii, problemy z aplikacjami bankowymi itp.)
Dostałem odpowiedź z githuba/domoticz, jak mozna sprzewdzić co w Domoticzu "blokuje" dostęp z Dataplicity.
Sciągnąłem Pull Request i dalej nie wiem co robić ("Setup a Linux Domoticz environment (using Docker for example)"). Mogę prosić szanownych Kolegów o poprowadzenie mnie przez te czynności. Od "and replace the domoticz binary with this version." myślę, że już wiem jak to zrobić 🙂
Oto odpowiedź z github:

There now is a (draft) Pull Request which has the current Beta code with some additional debug logging added.
This download contains the Linux binary for this particular PR build. Setup a Linux Domoticz environment (using Docker for example) and replace the domoticz binary with this version.
Now start this domoticz version with some extra startup flags. For example:
./domoticz -www 8080 -sslwww 0 -loglevel all -debuglevel webserver,received,auth
This will start domoticz with only the non-ssl webserver on port 8080 (or any port you prefer) and enable some additional debug logging.
Now try to connect to this domoticz instance through 'dataplicity.io' as you would normally do and look for debug information reporting the 'Request headers'. The information of the request headers should be in the log.
If you could post those here, we can take a look to see how the communication from dataplicity.io reached your Domoticz instance.

 
Dodane : 24/11/2022 11:35 am
 skom
(@skom)
Wpisów: 38
Kontrybutor
Autor tematu
 

Nikt nie pomoże? 🙁

 
Dodane : 30/11/2022 11:43 am
(@lucass94)
Wpisów: 1
Świeżak
 

@skom u mnie na ten sam problem pomogła zmiana adresu IP w zaufanych z 127.0.0.1 na 127.0.0.*, nie jestem pewien czy dostęp bez logowania dla tej całej puli jest bezpieczny. Ale połączenie zaczęło działać tak jak wcześniej

 
Dodane : 03/12/2022 11:00 pm
 skom
(@skom)
Wpisów: 38
Kontrybutor
Autor tematu
 

Niestety u mnie to nie zadziałało 🙁

 
Dodane : 06/12/2022 9:34 pm
(@s-k)
Wpisów: 1
Świeżak
 

Ja miałem podobny problem z dockerem na NASie QNAP. Na Raspberry wystarczyło zaufane IP 192.168.1.*, natomiast na QNAPie, ani to ani 127.0.* itd. dopiero *.*.*.* zadziałało (niby niebezpiecznie ale mam net mobilny i jestem za NATem).
Jeśli jednak możesz wpisać login i adres to dla Domoticza użyj admin/domoticz (default password).

 
Dodane : 08/12/2022 6:10 pm
 skom
(@skom)
Wpisów: 38
Kontrybutor
Autor tematu
 

Niestety  *.*.*.* też nie zadziało. Ale wielkie dzięki za chęć pomocy 🙂

 
Dodane : 09/12/2022 11:56 pm
Udostępnij: