Notifications
Clear all

[Rozwiązany] Sonoff Basic R2 - Problem z wifi - brak icmp, a ip assigned  

  RSS
yavorr
(@yavorr)
Młodzik

Hej,

SOnof Basic R2

Soft: AFE.firmware.1.2.4.T1.esp8285.1Mb.bin

Problem jest następujący.

Po wgraniu softu, połączeniu się do wifi, ustawieniu w konfiguracji sieci wifi, adresu (dhcp) następuje restart urządzenia. Jednak po uruchomieniu - nie pinga mi się. W routerze widzę, że pobrał adres, ale na zmianę jest deassigned - assigned.
W pierwszym sonofie miałem ten sam problem, jednak po kilkukrotnym załadowaniu softu - problem sam ustał i zaczęło to działać stabilnie, współpracować z domoticzem, a po odcięciu prądu i ponownym zasileniu wszystko OK.

Drugie urządzenie jest jednak uparte. Próbowałem już ustawiać innego trybu wgrywania, wedle Twoich instrukcji, jednak nie przynosi to oczekiwanych rezultatów.
Przede mną jeszcze 20 sonofów do wgrania, proszę o jakieś wskazówki, czego jeszcze można spróbować?
Jakieś pomysły z czym może to być związane? AP to cisco meraki mr33,router to mikrotik. Problemów z nimi raczej nie ma żadnych. W konfiguracji sonoff ustawione hasło, ssid poprawnie (łączy się, skoro dostaje adres z dhcp).

Dodane : 19/09/2018 7:53 pm
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2019, Donator 2K20

Możesz spróbować wgrać soft tak jak w tym wątku  https://www.smartnydom.pl/forum/diagnostyka/nagle-pady-sonoffow/

Ale zobacz czy przycisk na sonoff wprowadza moduł w tryb AP wciskasz na ponad 10 sekund , lub trzymasz powyżej 30 sek to reset  do fabryki .

Dodane : 19/09/2018 8:41 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

Pobierasz konfiguracje IP z routera automatycznie, czy wpisujesz ręcznie ?

Dodane : 19/09/2018 11:38 pm
_MarSs_
(@_marss_)
Majster Donator 2018

A sprawdziłeś, że na pewno jest esp8285? Bo w moich Basic R2 zarówno z tego jak i ubiegłego roku jest esp8266.

Może spróbuj wgrać blank.img i dopiero AFE. Ja dla pewności tak robiłem i szło bez problemu. Wgrywałem w trybie DOUT.

Dodane : 20/09/2018 5:10 pm
yavorr
(@yavorr)
Młodzik

Hej,

Wszystko się wyjaśniło. Wstyd przyznać, ale to Meraki wariował - albo sonoff "gubi" się przy wpa2 i kluczu. Na Mikrotiku CAP n2 i WPA poszło bez problemu.

Być może meraki ma konfigurację (której nie można zmienić), żeby odrzucać (deauth, dissociation) połączenia słabsze niż.. (tutaj wpisz któryś z parametrów, ccq, signal, tx, rx). W tym przypadku sonoff spina się zawsze na 1mbit - nie więcej - nawet przy świetnym sygnale, możliwe, że to też było przyczyną.

Dzięki za pomoc i sorry za zawracanie.. 🙂

Dodane : 21/09/2018 9:09 am
yavorr
(@yavorr)
Młodzik

Jeszcze tylko dodam, że adres dostawał z dhcp, po czym następowało dissociation z meraki .. i tak co X sekund (ustawionych w AFE) 🙂 Dlatego icmp nie odpowiadało

Dodane : 21/09/2018 9:10 am
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

ok, dzięki za info. dobrze ze działą. pozdrawiam, a.

Dodane : 21/09/2018 9:44 am
Udostępnij: