Środowisko programistyczne do AFE Firmware

adrian

Autor blog'a Smartny Dom

Subskrybuj
Powiadom o
10 komentarzy
najstarszy
najnowszy oceniany
Inline Feedbacks
View all comments
bom109

Dziękuję! U mnie wszystko działa, jedynie dodam, że po kompilacji pliku .bin szukajcie w zależności od wersji w „…\AFE-Firmware-master\T0\.pioenvs\esp8285\firmware.bin”.Jeszcze raz dziękuje i pozdrawiam! 🙂

mirmil99

czy ten opis jest aktualny? 🙂

mirmil99

Ok ja sobie ogarnalem i pod Atomem oczywiscie tez dziala, i spokojnie sie kompiluje;), pytanie bylo tylko o opis, bo faktycznie to teraz jaby prosciej jest, niz 2 lata temu  

mirmil99

@adrian

lib\AFE_APIs\AFE-MQTT.cpp: In member function ‚boolean AFEMQTT::listener()’:lib\AFE_APIs\AFE-MQTT.cpp:85:28: error: ‚class PubSubClient’ has no member named ‚topic’message.topic = Broker.topic;^lib\AFE_APIs\AFE-MQTT.cpp:86:30: error: ‚class PubSubClient’ has no member named ‚payload’message.content = Broker.payload;^lib\AFE_APIs\AFE-MQTT.cpp:87:29: error: ‚class PubSubClient’ has no member named ‚length’message.length = Broker.length;^*** [.pio\build\AFE_T0_8266_1m-generic-domoticz\liba23\AFE_APIs\AFE-MQTT.cpp.o] Error 1

 to moze podpowiesz czego brakuje dla wersji 2.1.0? doinstalowalem standardowe Arduinojson (wersja 5.x) i SubPubClient ale tu chyba trzeba czegos innego;), oczywiscie klonuje Afe-Firmware z Gita

mirmil99

@adriani od razu kompiluje sie i dziala AFE_T0_8266_1m-generic-domoticz;), wystarczylo PubSub, ArduinoJson chyba moze byc standardowe, natomiast z pewnych niewyjasnionych przyczyn wynikowy plik wyszedl o 1kB (390 672B) mniejszy niz ten zamieszczone przez Ciebie   

10
0
Would love your thoughts, please comment.x
()
x