Powiadomienia
Wyczyść wszystko

[Rozwiązany] Problem z sonoff-y 4ch T0

Daro1003
(@daro1003)
Ekspert Patron Strony Donator 2K19, Donator 2K20, Donator 2K21

Witam

Mam 15szt Sonoff 4ch w rozdzielni. Na wszystkich wgrana wersja T0 2.2.0 wszystko działa ale:

Jakiś czas temu - 3 tyg temu wystąpił problem że sonoff stracił połączenie z Domoticz ciągle migał oraz guziki na sonoff nie funkcjonowały zalogowałem się do niego przez IP i okazało się że w zakładce MQTT Broker w rubrykach są jakieś krzaki pytajniki i inne znaki uzupełniłem dane zrobiłem restart i ok działa,

Dziś stało się podobnie z innym Sonoff-em ale nie dało się z nim połączyć przez stałe IP tylko przez 192.168.5.1 - ciągle migał szybko jak w trybie konfiguracji po zalogowaniu okazało się że w zakładce sieć Wi-Fi są krzaki uzupełniłem dane zrestartowałem i ok.

Co może być problemem oprogramowanie ?Aktualizować na którą wersje ? Ostatnio wgrałem 3.0.1 do Wemosa i strasznie kiepsko działał wolno ładowały się strony załadowałem 3.0.0 i wszystko ok. 

Którą stabilna wersja T0 jest sprawdzona ? Na która aktualizować ?

Ogólnie mówiąc kiepski temat bo wprowadza zamęt w podstawowym sterowaniu oświetleniem.

Autor tematu Dodane : 15/04/2021 6:53 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony
  • te krzaki będą trudno diagnozowalne. Mialem w jednym sonoff coś takiego ze 2 lata temu po burzy. Problemy mogą być software, ale żeby to naprawić trzeba być w stanie to w powtarzalny sposób zreplikować i wyłapać. Problemy tez mogą być sprzętowe. Te kostki pamieć maja swoja żywotność ilosc odczytów / zapisów jest ograniczona - ogólnie mówiąc każda z tych kostek pamieć kiedyś padnie
  • co do stabilnej wersji ja używam tylko najnowszej. W domu mam wszystko na 3.0.1: Na Sonoffach, ESP12F od AI, Wemos v3
    • jak podeślesz mi tego Wemos'a to może będę w stanie coś zmienić w AFE. Tak to mam trudność żeby stwierdzić dlaczego masz takie zachowanie 

Pzdr.a

Dodane : 15/04/2021 9:50 pm
Daro1003
(@daro1003)
Ekspert Patron Strony Donator 2K19, Donator 2K20, Donator 2K21

A wiesz na wemosie mi nie zależy wgrałem inna wersje i jest Ok ale mogę podesłać te dwa wenosy co się na nich tak dzieje ale wemosa można podmienić również, większy problem z Sonoff  stało mi się to na dwóch Sonoff wersja Sonoff jedna z pierwszych kupione napewno rok temu lub więcej. Kolejne odkupione są nowsze w sumie mam 3 wersje. 
Co radzisz ? 
Co robić jak akcja się powtórzy ?? 

Spróbuje zaktualizować do najnowszej wersji skoro wszystko u ciebie śmiga. 

Autor tematu Dodane : 15/04/2021 10:18 pm
Daro1003
(@daro1003)
Ekspert Patron Strony Donator 2K19, Donator 2K20, Donator 2K21

Zrobiłem wczoraj  aktualizacje sonofa 4ch do wersji T0 3.0.1 no i @Adrian słabo dzisiaj widzę wolne działanie ładowanie strony ponad minutę, przejście między opcjami po 20 - 30 sekund identyczne problemy jak w wemos.

Zrobiłem aktualizacje do poprzedniej wersji T0 3.0.0 i całkiem inne działanie ładowanie strony w 2-3 sekundy przechodzenie po opcjach po kliknięciu wszystko działa ok na tej wersji.

Autor tematu Dodane : 16/04/2021 11:27 am
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20

T0 3.0.1 mam na kilku modułach ( rożnych ) wemos, sonoff i nie zauważyłem żeby coś wolno się ładowało czy działało. Wejście w konfig jest płynne i bieganie między zakładkami również. Samo działanie softu bez zastrzeżeń. 

Dodane : 16/04/2021 11:54 am
Daro1003
(@daro1003)
Ekspert Patron Strony Donator 2K19, Donator 2K20, Donator 2K21

No to dziwne wgram na najnowszego sonoffa jakiego ma w rozdzielni. 

Autor tematu Dodane : 16/04/2021 12:53 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

@daro1003 wydaje mi sie ze to nie jest zwiazane ze sprzetem tylko cos jest miedzy AFE + WiFi/Router/siecia.

Sprawdze w weekend jaka jest roznica miedzy T0.3.0.0 a T0.3.0.1 na tym polu

Najelpiej co moglbys zrobic do wgrac wersje 3.0.1 wersja DEBUG do Wemos i z dzialania i zrobic kopie log'ow i podeslac.

Dodane : 16/04/2021 2:39 pm
isom polubień
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20

Ja jestem bardziej niż pewny tego co wydaje się @adrian , soft sam w sobie jest ok 

Dodane : 16/04/2021 2:47 pm
Daro1003
(@daro1003)
Ekspert Patron Strony Donator 2K19, Donator 2K20, Donator 2K21

@isom to co nie gra ? Na 3.0.0 śmiga spoko. Sonoff i wemos łącząca się z wifi rożnych routerów ustawionych jako punkty dostępu tylko ale obydwa ogólnie wpięte do Halnego który przydziela IP. Wieczorem załaduje 3.0.1 do wemosa.

Autor tematu Dodane : 16/04/2021 2:59 pm
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20

@daro1003 wgraj wersję z debug , połącz wemosa przez usb z kompem , uruchom PUTTY i zrób zrzuty logów z modułu to @adrian będzie miał łatwiej coś odkryć .

 

Dodane : 16/04/2021 3:05 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

tutaj sa wszystkie zmiany miedzy wersja T0 3.0.0 a T0 3.0.1

  • Zmienilem odpytywanie czy urzadzenie ma dostep do internetu z odpytywania z wykorzystywanie nazwy hosta na IP address
  • wprowadzilem dodatkowe 20 milisekund podczas laczenia sie do WiFi

 

 

Dodane : 16/04/2021 3:16 pm
Daro1003
(@daro1003)
Ekspert Patron Strony Donator 2K19, Donator 2K20, Donator 2K21

Ok panowie wieczorem zarobię. 

Dzięki @isom za instrukcje bo nie wiedziałem jak mam logi zaczynać. W Putty jak to robię ?? 

Autor tematu Dodane : 16/04/2021 3:23 pm
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20

W Putty ustawiasz COM port taki na jakim będzie wemos , wemosa skonfiguruj do pracy z Twoją siecią i ustaw sobie jakieś GPIO do testów np przekaźnik , i jak zrobisz reset wemosa tym malutkim przyciskiem to potem zacznie się magia na ekranie putty . Ta magię najlepiej kopiować albo zrobić zrzuty

Dodane : 16/04/2021 3:30 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

Daro, a powiedz mi dalej nie mozesz wprowadzic klucza do Pro w AFE? bo moze masz cos w routerze co blokuje jakies "operacje" sieciowe i wskakuja jakies timeout'y ktore cos blokuja?

Dodane : 16/04/2021 4:37 pm
Daro1003
(@daro1003)
Ekspert Patron Strony Donator 2K19, Donator 2K20, Donator 2K21

@adrian wersja pro się ładuje ładnie znalazłem u siebie defekt miałem źle wpisaną maskę i bramę - zamienioną miejscami. Po odpowiednim uzupełnieniu jest ok pro się ładuje. Sprawdzę zaraz wersje 3.0.1

Autor tematu Dodane : 16/04/2021 6:12 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

Co to znaczy, ze masz internet 🙂 jestes np, pewny ze nie blokujesz pakietow ICMP, ktore sa wykorzystywane do ping'owania, a nie sa np. potrzebne do przegladania strony www, poczty?

Wydaje mi sie, ze u Ciebie trzeba szukac problemow gdzie indziej niz tylko w AFE, rozumiem, ze w niektorych wersjach chodzi dobrze, w niektorych nie i to mnie nurtuje. 

Moze byc ze AFE dziala wolno, bo probuje sie gdzies przebic przez Twoje ustawienia w sieci i nie moze i ma dlugie czasy oczekiwan (timeout'y)

Mozesz sprobowac zrobic HotSpot ze swojej komorki i do niego podlaczyc ESP i zobaczyc czy dziala "szybko"

Dodane : 16/04/2021 6:32 pm
Daro1003
(@daro1003)
Ekspert Patron Strony Donator 2K19, Donator 2K20, Donator 2K21

Zanim @Adrian edytowałem wpis Ty mi odpisałeś a więc jeszcze raz: znalazłem u siebie defekt miałem źle wpisaną maskę i bramę - zamienioną miejscami. Po odpowiednim uzupełnieniu jest ok pro się ładuje i internet jest. Sprawdzę zaraz wersje 3.0.1

Autor tematu Dodane : 16/04/2021 6:47 pm
Daro1003
(@daro1003)
Ekspert Patron Strony Donator 2K19, Donator 2K20, Donator 2K21

Zaktualizowałem kilka sonoff i działają odpowiednio. Problem był w błędnym ustawieniu maski i bramy jak @Adrian pisał AFE próbował przebić się przez te błędne ustawienia sieciowe.

Autor tematu Dodane : 17/04/2021 8:34 am
adrian polubień
Udostępnij: