Powiadomienia
Wyczyść wszystko

Uwaga: Trwają prace modernizacyjne na serwerze Smart'ny Dom. Strona może nie być czasowo dostępna do 26.09.2021 18:00. Aktualny stan prac.

Z góry przepraszam. admin

[Rozwiązany] Brak sterowania offline T0 afe 2.1.1

stefan1818
(@stefan1818)
Początkujący Donator 2K20

Witam, mam obecnie duży problem sprzętowy i musiałem wyłączyć serwer home assistant.

Teraz kiedy nie działa mqtt wszystkie przełączniki pulsują powoli i nie da się ich używać - afe 2.1.1 T0. Próbowałem coś poustawiać, ale z marnym skutkiem, a dopiero koło środy postawię serwer...

Da się to jakoś ogarnąć? Najlepiej jak by można było ustawić możliwość sterowania fizycznego przełącznikiem kiedy broker nie jest dostępny.

Autor tematu Dodane : 24/01/2021 12:00 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

zaktualizuj jeden do najnowszej wersji i zobacz czy problem dalej występuje, pozdrawiam

https://www.smartnydom.pl/download/afe-firmware-t0-2-4-1/

Dodane : 24/01/2021 12:55 pm
stefan1818
(@stefan1818)
Początkujący Donator 2K20

@adrian

Dzięki za pomoc, zaktualizowałem do wersji T0 2.4.1 i nic to nie dało. Kiedy serwer mqtt jest wyłączony przecisk miga (powoli) i w tym czasie nie da się nic zrobić fizycznie.

konfiguracja:

Ilość ledów: 1

ilość przekaźników: 1

ilość przycisków :1

Sterowanie: MQTT

Wifi: aktywne

IP: statyczne

Ilość prób łączenia: 30

czas pomiędzy prób.: 1

czas po jakim powt. próby: 20

Broker:

Hostname: brak

Ip: ustawione

Port: 1883

User/hasło: ustawione

limit czasu odp.: 5000

Temat: dom/lazienka/swiatlo/lwt

LED#1

GPIO: 13

Zmień świecenie diody na odwrotne: tak

Led systemowy: 1

PRZEKAŹNIK#1

GPIO: 12

nazwa: relay

po przywr. zas: ostatnia zap. wartość

po podł. do brokera mqtt: brak akcji

wyłącz po: 0.0

led (stan): brak

Temat ster. przekaźn: dom/lazienka/swiatlo

PRZYCISK/WYŁĄCZNIK #1

GPIO: 0

funkcja: przycisk systemowy

Sterowanie: przek. 1

typ: monostabilny

czułość: 50

Temat: dom/lazienka/swiatlo

Pro: tak

Autor tematu Dodane : 24/01/2021 3:27 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

@stefan1818 muszę t w takim razie przeanalizować ponownie,  już coś takiego rozwiązywałem. 

propozycja, żebyś mógł jakoś funkcjonować - w konfiguracji AFE wyłącz na ten czas MQTT API.

Dodane : 24/01/2021 4:40 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

@stefan1818 a napisz mi jeszcze 

  • włącznik po 30 mrugnięciach powinien przestać na 20sek
  • podczas tych 20sek - też nie da się przełączać? 
Dodane : 24/01/2021 5:25 pm
stefan1818
(@stefan1818)
Początkujący Donator 2K20

Musiałem sprawdzić. Faktycznie kilka sekund pomiędzy tym miganiem da się włączyć.

Autor tematu Dodane : 24/01/2021 5:48 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

czy ten serwer na którym stał HA jest dostępny? pytam w zasadzie czy IP adres jest w Twojej domowej sieci jest dostępny

Dodane : 24/01/2021 5:54 pm
stefan1818
(@stefan1818)
Początkujący Donator 2K20

@adrian

Tak serwer stoi u mnie w sieci lokalnej.

Autor tematu Dodane : 24/01/2021 6:02 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

@stefan1818 tak, ale czy jest dostępny, włączony teraz?

Dodane : 24/01/2021 6:39 pm
stefan1818
(@stefan1818)
Początkujący Donator 2K20

Teraz włączyłem bo nie mogłem sterować światłem. Tylko postawiłem na innej fizycznej maszynie konfiguracja odtworzona z backupu. Ale stoi na tym samym IP.

Autor tematu Dodane : 24/01/2021 6:44 pm
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20

@stefan1818 na 100% będzie działać jak wyłączysz API MQTT i włącz API HTTP ustawienia tak jak masz , wtedy moduł nie dobija się do brokera i działa 

Dodane : 24/01/2021 7:03 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

Myślę - że jeśli ten objaw jest na wyłączonym serwerze - nie oprogramowaniu MQTT Broker - to odnajdywanie nieistniejącego IP w sieci ma duży timeout i blokuje AFE - natomiast dalej nie wiem czy ten objaw był na wyłączonym serwerze (sprzęcie)

Dodane : 24/01/2021 7:12 pm
stefan1818
(@stefan1818)
Początkujący Donator 2K20

@adriantak ten objaw występuje przy awarii serwera -czytaj wyłączyłem serwer. IP był niedostępny. Rozumiem że nie da się ustawić takiej opcji która przy utracie połączenia z brokerem (pada serwer) pozwala jednak wyłączyć/włączyć fizycznym przyciskiem ?

Autor tematu Dodane : 24/01/2021 7:23 pm
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20

Jak wykasujesz IP brokera to działa 100/100 , jak padnie serwer i AFE nie widzi IP to zaczyna się blokować i działa od przypadku do przypadku ( przerwy w próbach łączenia)

Dodane : 24/01/2021 7:26 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

Problem nie jest z brokerem w tym przypadku. Jak wyłączysz broker w tym "tymczasowym" serwerze to powinno działać.

Problem jest bardziej sieciowy, wyszukiwanie serwera o adresie IP - tam gdzie stoi broker blokuje oprogramowanie - muszę pomyśleć jak takie coś rozwiązać. Na teraz w takiej sytuacji wyłącza MQTT API w konfiguracji AFE i będzie działać - bez potrzeby stawiania dodatkowego serwera tymczasowego.

Dodane : 24/01/2021 7:35 pm
stefan1818
(@stefan1818)
Początkujący Donator 2K20

Ok jak nie można inaczej to póki co zrobię tak.

Autor tematu Dodane : 25/01/2021 7:32 am
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

@stefan1818 zrobiłem wersję AFE, która powinna rozwiązywać ten problem. Więcej info tutaj.

Dodane : 30/01/2021 5:28 pm
stefan1818
(@stefan1818)
Początkujący Donator 2K20

Witaj, dzięki za reakcję i szybką poprawkę.

Sprawdziłem póki co na dwóch T0 G1 i dwóch T0 G2 i działa wg Twoich założeń. Po wyłączeniu serwera mqtt przez jakiś czas jeszcze miga (kilka sekund ustawionych w tym parametrze) potem zaczyna świecić światłem ciągłym i da się już sterować normalnie.

Autor tematu Dodane : 01/02/2021 6:41 pm
adrian polubień
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

@stefan1818 super, dzięki za info - nie miałem jak sprawdzić w warunkach rzeczywistych.

pozdrawiam

Dodane : 01/02/2021 9:32 pm
Udostępnij: