Powiadomienia
Wyczyść wszystko

Nowa stacja pogody.

steel_rat
(@steel_rat)
Ekspert

Od wczoraj mam stacje pogody od @Lukas121.

Fajna stacja niestety są też rzeczy do poprawy.

1) Zamienione są domyślnie numery GPIO dla UART.

2) Jest też problem z czujką temperatury. Jest wykrywana jako [0x76] BMx280 a komunikuje się tylko jak wybiorę poniżej czujnik BMx680 wtedy są dane wyświetlane.

Mogłoby to tak działać gdyby nie to że np. przez całą noc tak od 1 do 6:24 miałem temperaturę na dworze 80st.C z wahaniami do 77st.C. Teraz do 12:45 do 13:50 było w okolicach 50 st. C na dworze.

Jak w środku jest czujka to nie wiem bo nie dostałem jeszcze odpowiedzi od @Lukas121. Myślę, że jednak tam jest BMx280 a nie BMx680.

Soft wgrany

AFE.Firmware.T6.2.3.1.PL.ESP8266.WeatherStationV2.1iECS.4Mb

Ps. Dla wiatromierza jednostka Centymetry, Metry, Kilometry to co oznacza? To ma być średnica śmigła czy co?

Cytuj
Autor tematu Dodane : 28/01/2021 2:37 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

@steel_rat

ad1) co dokładnie znaczy, że zamienione są domyślne GPIO UART? jak powinno być?

ad2) jaki jest tam czujnik musisz wybrać sam. AFE wykrywa, że jest jakieś urządzenie z adresem [0x76] i najczęściej bywa to BMx280, ale wcale tak nie musi być. Wiele urządzeń ma możliwość ustawienia własnych adresów

Kalibracji podobna jak w liczniku rowerowym. Musisz znać obwód koła. Czyli ile jest cm lub m lub km na jeden obrót (a w zasadzie jeden impuls ) wiatraka. W przypadku wiatraka @lukasa121 to jest 25cm lub 0.25m - o ile cos sie nie zmieniło

Tutaj więcej info, które powstało w czasie tworzenia tej wersji AFE.

OdpowiedzCytuj
Dodane : 28/01/2021 3:10 pm
steel_rat
(@steel_rat)
Ekspert

No dobra rozumiem że w pierwsze pole to typ czujnika a potem określam jaki mam dokładnie czujnik. Tylko z skąd te dziwne wartości w nocy 80st.C/100% a niedawno 50st.C/100%. Tak to cały czas mam dobre wartość c

Co do UART to domyślnie było GPIO RXD 3 a GPIO TXD 1. Dopiero zamiana tych wartości zmusiła do działania czujnik pyłu. 

OdpowiedzCytuj
Autor tematu Dodane : 28/01/2021 3:33 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony
  • pierwsze pole to adres czujnika na szynie I2C nie typ.
    • na tej liści pokazuje też potencjalny typ czujnika jaki to może być. Używałem tę listę - ale jak napisałem potencjalnie - nie ma możliwości łatwo zdiagnozować jaki typ czujnika siedzi na konkretnym adresie. To musisz samemu określić wpisują w kolejnym polu.
  • drugie to typ czujnika

 

Standardowo w ESP RX to GPIO3, a TX to GPIO1 - więc mam wątpliwość, czy jest to problem z AFE Firmware. Natomiast sprawdzę jeszcze raz we "flakach" AFE

Co do pomiarów w domu używam BME680, podłącze BME280 wieczorem i zobacze, czy jest jakiś problem, który nie wyszedł podczas moich testów.

Dobrze, jakbyś mógł zerknąć, jaki konkretnie masz tam czujnik: BMP085, BMP180, BMP280, BME280, BME680 - mam w domu tylko 2 ostatnie 

 

OdpowiedzCytuj
Dodane : 28/01/2021 4:20 pm
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2019, Donator 2K20

Firmware na bank działa dobrze z BME 280 

OdpowiedzCytuj
Dodane : 28/01/2021 6:25 pm
steel_rat
(@steel_rat)
Ekspert

Tak to jest czujnik BMx680. Ale istnieje możliwość że jest popsuty.

A tak wygląda wykres. Czujnik na dachu.

 

 Temp
OdpowiedzCytuj
Autor tematu Dodane : 28/01/2021 7:49 pm
lukas121
(@lukas121)
Ekspert Donator 2019 Zasłużony dla Forum

Chyba to jednak nie wina czujnika. Nowy czujnik zamontowałem u siebie i po pewnym czasie mam taki sam objaw jak u ciebie. @Adrian jakieś sugestie ?

OdpowiedzCytuj
Dodane : 06/02/2021 9:44 am
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

log przydałby się z działania - do ściągnięcia po wgraniu wersji DEBUG

Dzisiaj  / jutro puszczę nową wersję firmware 

OdpowiedzCytuj
Dodane : 06/02/2021 11:01 am
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

@steel_rat ten probem masz dalej?

OdpowiedzCytuj
Dodane : 22/02/2021 9:27 pm
steel_rat
(@steel_rat)
Ekspert

I tu trzeba z lukas121 porozmawiać na razie wysłał mi czujkę starszą 280 i na niej działam. Te 680 to nawet jak lukas121 zamówił nową to też był problem. Mówił, że Tobie jedną wyśle.. Jak się rozwiąże problem z czujką 680 to ma mi zamienić na nią.

OdpowiedzCytuj
Autor tematu Dodane : 22/02/2021 9:47 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

tak poprosiłem go żeby podesłał mi - ja mam w domu tylko 680 i działają bez zastrzeżeń. dobra czekam, pzdr. a

OdpowiedzCytuj
Dodane : 22/02/2021 10:12 pm
Udostępnij: