Powiadomienia
Wyczyść wszystko

[Rozwiązany] Sonoff basic RF Afe działa bardzo dziwnie

Strona 1 / 2
Robert
(@robert)
Młodzik

Witam,

Nie wiem czy afe jest dostosowane do sonoff RF ale wgrałem i mam bardzo dziwne objawy czyli po włączeniu do prądu dioda mruga poprawnie jak loguje sie do sieci, po zalogowaniu zgaśnie i niby wszystko jest ok przez kilkanaście sekund a później dioda sama z siebie zaczyna cały czas mrugać jak szalona (właściwie to cały czas świeci i mruga z dużą częstotliwością).

Przy próbie załączenia przekaźnika z domoticz nic się nie dzieje ale po kilkunastu sekundach przekaźnik załącza się i wyłącza samoczynnie.

Afe wgrywałem z DOUT oraz QIO. Moja wersja sonoff rf wyglada tak: https://elty.pl/pl/p/Sonoff-RF-przelacznik-sterowany-WiFi-oraz-RF433MHz/1819  

 

Autor tematu Dodane : 29/12/2018 4:17 pm
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20

Może napisz kolego jaką wersję AFE wgrałeś ? T-? Czym wgrywałeś ? Czy i jak skonfigurowałeś ustawienia do własnych potrzeb ?

 

Dodane : 29/12/2018 4:43 pm
Robert
(@robert)
Młodzik

Wersja jaką wgrałem to "AFE.firmware.1.3.0.T0.esp8266.1Mb.bin" Od miesiąca używam tej samej wersji na sonoff basic bez RF i śmiga bezproblemowo. Korzystam z domoticz wiec pod ten system skonfigurowałem. Sprawdziłem jest kilka razy i zawsze po włączeniu zasilania i zalogowaniu do sieci dioda zaczyna mrugać dopiero po około jednej minucie.

Autor tematu Dodane : 29/12/2018 4:48 pm
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20

Spróbuj wgrać wersję dla ESP-8285 , przy sonoff basic w wersji TH 1,1 i R2 ten soft działa może na twoim też zadziała

Dodane : 29/12/2018 4:57 pm
Robert
(@robert)
Młodzik

Dzięki za naprowadzenie na dobry trop. Jako, że esp jest schowane pod płytką RF to wcześniej tego nie sprawdziłem ale po Twojej uwadze sprawdziłem pod lupą i siedzi tam ESP-8285. Wgranie afe dla 8285 nic nie dało ale teraz chyba trzeba wgrać pusty i dopiero afe, sprawdzę i dam znać.

Autor tematu Dodane : 29/12/2018 5:14 pm
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20

Wgraj blanka potem AFE i daj znać koniecznie . Przyda się innym co mają takie sonoffy .

Dodane : 29/12/2018 5:20 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

hm...... takie bardzo szybkie miganie diody występuje po ok 35sekundach gdy wciśnie się przycisk, który jest skonfigurowany jako systemowy

A jak podłączysz zasilanie to nie mrugnie po 5 sekundach, później mrugnie 2x po 10 sekundach, później 3x po 30sek a po 35 mruga z bardzo dużą częstotliwością?

Dodane : 29/12/2018 7:23 pm
Robert
(@robert)
Młodzik

Nie sprawdziłem bardzo dokładnie tego mrugania wiec pewności nie mam. Wgrałem Esp Easy dla 8285 i wszystko działa bez problemu po wpisaniu formułek w rules, później wgrałem AFE wersje 8285 i nie działa tak jak powinno. Przy próbie załączenia przekaźnika czy z pilota czy poprzez domoticz przekaźnik sam sie włącza i wyłącza co sekundę. Jutro coś podziałam bo na dziś mam dość. Mógłbym zostawić esp easy, które działa ale afe jest dla mnie idealne gdyż na sonoff bez rf działa tak jak tego oczekuję więc i na tym musi działać.

Autor tematu Dodane : 29/12/2018 9:05 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

ciekawostka - muszę sobie takiego kupić. 

Może w tym nowym są inaczej GPIO - jeśli  przekaźnik pyka co 1 sek to może jest podłączony pod GPIO Led'a, który mruga co sekundę gdy łaczy się do WiFI

  • przestaje pykać przekaźnik po jakimś czasie?
  • jak zachowuje się dioda?
  • jaki masz GPIO dla diody i przekaźnika?

 

Dodane : 29/12/2018 9:18 pm
Robert
(@robert)
Młodzik

GPIO są identyczne gdyż na esp easy działa bez problemu tak jak pisałem wcześniej. Dla tych co nie chcą kombinować napisze, że ta wersja sonoff rf działa bezproblemowo z tasmotą bez zbędnych konfiguracji, wystarczy tylko wybrać model "Sonoff Rf" i wszystko działa super.

Wgrałem dziś ponownie AFE i po minimalnej konfiguracji działało bezproblemowo czyli przez komendy http ( http://192.168.8.157/?device=relay&name=switch&command=on) załączało i wyłączało przyciskiem z domoticza jak również pilot działał tak jak powinien ale gdy dopisałem idx przycisku to wtedy zaczęła się szopka z samoczynnym włączaniem przekaźnika i dziwnym mruganiem led.

Załączam zdjęcie mojego sonoff, odpadł przycisk ale nie ma to wpływu na działanie.

 

sonoff rf2
Autor tematu Dodane : 30/12/2018 10:12 am
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20

@viper80 gdzie dopisałeś IDX przycisku ? W konfiguracji AFE T-0 nie występuje IDX przycisku . Dodatkowo komendy wyzwalające akcje przy współpracy z domoticz powinny wyglądać tak 

http://xxx.xxx.x.xx/?device=relay&name=nazwa-przekaźnika&command=on&source=domoticz

 

Dodane : 30/12/2018 12:52 pm
adrian polubień
Robert
(@robert)
Młodzik

W ustawieniach AFE jest taka opcja "IDX in Domoticz*" zakładka "switch"

Autor tematu Dodane : 30/12/2018 3:24 pm
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20

Jest ale dla przekaźnika 

T 0 relay
 
Dla przycisku wygląda to tak 
T 0
Dodane : 30/12/2018 3:36 pm
adrian polubień
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

skopiuj i wklej tutaj akcje włącz / wyłacz, które masz wprowadzone w Domoticz pod tym urządzeniem

Dodane : 30/12/2018 3:38 pm
Robert
(@robert)
Młodzik

Moja akcja wygląda tak: "http://192.168.8.168/?device=relay&name=went&command=on" ale to powinno działać bez jakichkolwiek akcji tylko poprzez idx tak jak działa to doskonale w tasmota.

IDX musi być dopisany ponieważ jak załączę przekaźnik pilotem to stan przycisku w domoticz musi się również zmienić. Jako przycisk u mnie działa pilot wiec przekaźnik można załączyć przyciskiem, pilotem i poprzez domoticz.

Autor tematu Dodane : 30/12/2018 4:04 pm
isom
 isom
(@isom)
Prezes Moderator Zasłużony dla Forum, Donator 2K19, Donator 2K20

@viper80 Tasmota to mqtt czyli całkiem inna komunikacja , a po http powinieneś używać poprawnych komend , które zwrócą stan sonoffa do domoticza ( podałem przkłąd komendy wcześniej)

Dodane : 30/12/2018 4:15 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

 Akcje są złe. Zmień na te co napisał @isom

bez dopisanego &source=domoticz 

domoticz będzie włączał wyłącza przekaźnik w petli 

Po wpisaniu poprawnych akcji tez będzie ci działać doskonale z AFE

IDX - jest potrzebny żeby wysłać status do domoticz

akcje są potrzebne żeby sterować z domoticz przelacznikiem

Akcje do sterowa sa inne z domoticz niż czyste’ akcje http

Dodane : 30/12/2018 4:15 pm
isom polubień
Robert
(@robert)
Młodzik

Może i akcje są złe ale na sonoff basic bez rf wszystko działa od miesiąca bez absolutnie żadnych problemów. Używam tego sonoff do włączania wentylatora w łazience, załącza się ręcznie przez domoticz lub jak zostanie przekroczona określona wilgotność ale żona chciała mieć fizyczny przycisk dlatego zamówiłem sonoff RF.

Na sonoff bez rf mam dokładnie takie same ustawienia i takie same akcji a problemów z działaniem żadnych.

Jak będę miał chwile czasu to sprawdzę to coś zmieni http://xxx.xxx.x.xx/?device=relay&name=nazwa-przekaźnika&command=on&source=domoticz

 

Autor tematu Dodane : 30/12/2018 7:19 pm
adrian
(@adrian)
Prezes Zasłużony dla Forum, Patron Strony

@viper80 - akcje są złe, nie może są złe. Sprawdź akcje włącz/wyłącz w tym drugim sonoff'ie.

Jest to opisane w każdej wersji AFE dla Domoticz, że tak trzeba zdefiniować akcje, żeby wyeliminować "looping" który występuje szczególnie, gdy przekaźnikeim steruje się dodatkowo fizycznych przyciskiem

Chcemy Ci pomóc nie udawadniać sobie co działa, a co nie. 

Pozdrawiam

 

Dodane : 30/12/2018 7:36 pm
Robert
(@robert)
Młodzik

Sorry, źle się wyraziłem. Akcje są złe ale zastanawia mnie to jakim cudem u mnie wszystko działa na sonoff basic. Nawet przed chwilą sprawdziłem i przy użyciu przycisku nie zapętla się a teoretycznie powinno. Przy sonoff rf popełniłem błąd bo założyłem, że jest to ESP-8266 a dodatkowo błędne akcje zrobiły swoje.

Autor tematu Dodane : 30/12/2018 7:54 pm
Strona 1 / 2
Udostępnij: